summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-10-22 20:44:54 +0000
committerDaniel Bermond2018-10-22 20:44:54 +0000
commit080b11e7080690af1267dcbacbd938b2a98cb124 (patch)
treed0d0f7af689d43172ffb141e3b0840017f98e650
parentf6fe3579093c49705bd053e12beba91ef20027ae (diff)
downloadaur-080b11e7080690af1267dcbacbd938b2a98cb124.tar.gz
Fixes
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD24
2 files changed, 13 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f4eccb57cc9..14d55390ba5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xavs2-git
pkgdesc = Open-Source encoder of AVS2-P2/IEEE1857.4 video coding standard (git version)
- pkgver = 1.0.r79.g81c9d9b
+ pkgver = 1.0.r135.g1ff3ff8
pkgrel = 1
url = https://github.com/pkuvcl/xavs2/
arch = i686
@@ -13,11 +13,9 @@ pkgbase = xavs2-git
depends = glibc
depends = liblsmash.so
provides = xavs2
- provides = libxavs2
provides = libxavs2-git
provides = libxavs2.so
conflicts = xavs2
- conflicts = libxavs2
conflicts = libxavs2-git
replaces = libxavs2-git
source = xavs2-git::git+https://github.com/pkuvcl/xavs2.git
diff --git a/PKGBUILD b/PKGBUILD
index 65837561b3b7..bb45dedf7452 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
-# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
+# Maintainer : Daniel Bermond < gmail-com: danielbermond >
# NOTE:
# 10-bit depth currently fails to build
# https://github.com/pkuvcl/xavs2/issues/9
pkgname=xavs2-git
-pkgver=1.0.r79.g81c9d9b
+pkgver=1.0.r135.g1ff3ff8
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc='Open-Source encoder of AVS2-P2/IEEE1857.4 video coding standard (git version)'
@@ -13,8 +13,8 @@ url='https://github.com/pkuvcl/xavs2/'
license=('GPL')
depends=('glibc' 'liblsmash.so')
makedepends=('git' 'gcc7' 'yasm' 'l-smash')
-provides=('xavs2' 'libxavs2' 'libxavs2-git' 'libxavs2.so')
-conflicts=('xavs2' 'libxavs2' 'libxavs2-git')
+provides=('xavs2' 'libxavs2-git' 'libxavs2.so')
+conflicts=('xavs2' 'libxavs2-git')
replaces=('libxavs2-git')
source=("$pkgname"::'git+https://github.com/pkuvcl/xavs2.git')
sha256sums=('SKIP')
@@ -24,6 +24,11 @@ prepare() {
# use gcc7 (it does not build with gcc8)
sed -i 's/gcc/gcc-7/' build/linux/configure
+
+ # must copy the entire source tree for each build or it will not work
+ cd "$srcdir"
+ cp -af "$pkgname" build-8bit
+ cp -af "$pkgname" build-10bit
}
pkgver() {
@@ -34,12 +39,7 @@ pkgver() {
}
build() {
- # must copy the entire source tree for each build or it will not work
- cd "$srcdir"
- cp -af "$pkgname" build-8bit
- cp -af "$pkgname" build-10bit
-
- msg2 'Building for 8-bit...'
+ printf '%s\n' ' -> Building for 8-bit...'
cd build-8bit/build/linux
./configure \
--prefix='/usr' \
@@ -54,7 +54,7 @@ build() {
--disable-gpac
make
- msg2 'Building for 10-bit...'
+ printf '%s\n' ' -> Building for 10-bit...'
cd "${srcdir}/build-10bit/build/linux"
if ./configure \
--prefix='/usr' \
@@ -82,7 +82,7 @@ package() {
for _depth in 10 8
do
- msg2 "Installing for ${_depth}-bit..."
+ printf '%s\n' " -> Installing for ${_depth}-bit..."
if [ "$_depth" -eq '10' ] && ! [ -d 'build-10bit' ]
then