summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-11-17 12:17:19 +0000
committerDaniel Bermond2018-11-17 12:17:19 +0000
commite4834b2864575702f748172ce08713b0f7f7d2b7 (patch)
treefdbf4a955422c910a8d89bd0ce2aa309996d1670
parente8327f50e8a6d6fe5188e11f093da2e98fe76ebd (diff)
downloadaur-e4834b2864575702f748172ce08713b0f7f7d2b7.tar.gz
Do not copy source tree for an 8-bit only build
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 6 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 57a55cf1a188..163038428c9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xavs2-git
pkgdesc = Open-Source encoder of AVS2-P2/IEEE1857.4 video coding standard (git version)
- pkgver = 1.0.r136.gdc1894c
- pkgrel = 2
+ pkgver = 1.2.r109.g9a06546
+ pkgrel = 1
url = https://github.com/pkuvcl/xavs2/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 246a4512e962..46b8dca7a774 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
pkgname=xavs2-git
_srcname=xavs2
-pkgver=1.0.r136.gdc1894c
-pkgrel=2
+pkgver=1.2.r109.g9a06546
+pkgrel=1
arch=('i686' 'x86_64')
pkgdesc='Open-Source encoder of AVS2-P2/IEEE1857.4 video coding standard (git version)'
url='https://github.com/pkuvcl/xavs2/'
@@ -25,10 +25,6 @@ prepare() {
# use gcc7 (it does not build with gcc8)
sed -i 's/gcc/gcc-7/' build/linux/configure
-
- # must copy the entire source tree or it will not work
- cd "$srcdir"
- cp -af "$_srcname" build-8bit
}
pkgver() {
@@ -39,7 +35,7 @@ pkgver() {
}
build() {
- cd build-8bit/build/linux
+ cd "${_srcname}/build/linux"
./configure \
--prefix='/usr' \
@@ -57,5 +53,5 @@ build() {
}
package() {
- make -C build-8bit/build/linux DESTDIR="$pkgdir" install-cli install-lib-shared
+ make -C "${_srcname}/build/linux" DESTDIR="$pkgdir" install-cli install-lib-shared
}