summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWolf2018-01-10 18:03:52 +0100
committerWolf2018-01-10 18:03:52 +0100
commitdb8e790cc14cf6248bc04eb9b207245084ac471d (patch)
tree5720bbffbe9a63e5736384ee2626ae8b8ed516fb
parentef67e1057a501617f6be92e9bdc8b04af2810952 (diff)
downloadaur-db8e790cc14cf6248bc04eb9b207245084ac471d.tar.gz
Fix submodule
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
2 files changed, 17 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 719ff37a5b25..4aea6e22000e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xbase
pkgdesc = A C++ library
pkgver = 3.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/graywolf/xbase
arch = i686
arch = x86_64
@@ -11,6 +11,8 @@ pkgbase = xbase
depends = gcc-libs
options = staticlibs
source = git+https://github.com/graywolf/xbase#tag=3.3.0
+ source = git+https://github.com/3rd_party/googletest
+ sha512sums = SKIP
sha512sums = SKIP
pkgname = xbase
diff --git a/PKGBUILD b/PKGBUILD
index d4249fd60c7d..7b7375b66036 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=xbase
pkgver=3.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="A C++ library"
arch=('i686' 'x86_64')
url='https://github.com/graywolf/xbase'
@@ -13,11 +13,22 @@ depends=('gcc-libs')
makedepends=('git' 'cmake')
options=(staticlibs)
-source=("git+https://github.com/graywolf/xbase#tag=${pkgver}")
-sha512sums=('SKIP')
+source=(
+ "git+https://github.com/graywolf/xbase#tag=${pkgver}"
+ "git+https://github.com/3rd_party/googletest"
+)
+sha512sums=(
+ 'SKIP'
+ 'SKIP'
+)
prepare() {
cd "${pkgname}"
+
+ git submodule init
+ git config submodule.3rd_party/googletest.url "${srcdir}/googletest"
+ git submodule update
+
mkdir -p build
}