summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2016-09-09 02:33:40 +0200
committerNarrat2016-09-09 02:33:40 +0200
commit52485b2b3db171025ba17be265a8a96dcc83d3f3 (patch)
treed24ca7ca4fe27646265a10e9650e6a4b30acc72f
parentf6f307b886f2f6dace6a446d952a606f8dc45db9 (diff)
downloadaur-52485b2b3db171025ba17be265a8a96dcc83d3f3.tar.gz
xbelld: Upstream url adjusted
and removed base-devel package from dep, as those are a requirement for the AUR and shouldn't be added
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
2 files changed, 18 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0fff6e022e78..f0a40ff741ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Sep 9 00:33:28 UTC 2016
pkgbase = xbelld
pkgdesc = X daemon that performs an action every time the bell is rung
pkgver = 0.3.3
- pkgrel = 4
- url = http://code.google.com/p/xbelld/
+ pkgrel = 5
+ url = https://gitlab.com/gi1242/xbelld
arch = i686
arch = x86_64
license = GPL3
+ makedepends = git
depends = xorg-server
- depends = pkgconfig
depends = alsa-lib
- source = http://xbelld.googlecode.com/files/xbelld-0.3.3.tbz2
- md5sums = d6c9b96ac5ccd4a3072e4c9e7add6547
+ source = git+https://gitlab.com/gi1242/xbelld.git#commit=8d79553d
+ md5sums = SKIP
pkgname = xbelld
diff --git a/PKGBUILD b/PKGBUILD
index 995a3a2779d5..44a838d19a77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,28 @@
-# Maintainer: Scott Lawrence <bytbox@gmail.com>
+# Contributor: Scott Lawrence <bytbox@gmail.com>
# Contributor: Scott Smith <jcdenton513@gmail.com>
# Contributor: tuxce <tuxce.net@gmail.com>
# Contributor: teddy_beer_maniac <teddy_beer_maniac@wp.pl>
pkgname=xbelld
pkgver=0.3.3
-pkgrel=4
+pkgrel=5
pkgdesc="X daemon that performs an action every time the bell is rung"
-url="http://code.google.com/p/xbelld/"
+url="https://gitlab.com/gi1242/xbelld"
arch=('i686' 'x86_64')
license=('GPL3')
-depends=('xorg-server' 'pkgconfig' 'alsa-lib')
-source=(http://xbelld.googlecode.com/files/xbelld-${pkgver}.tbz2)
-md5sums=('d6c9b96ac5ccd4a3072e4c9e7add6547')
+depends=('xorg-server' 'alsa-lib')
+makedepends=('git')
+source=(git+https://gitlab.com/gi1242/xbelld.git#commit=8d79553d)
+md5sums=('SKIP')
+
build() {
- cd $startdir/src/$pkgname-$pkgver
- LDFLAGS=-lm make || return 1
+ cd "$pkgname-$pkgver"
+ LDFLAGS=-lm make
}
package() {
- cd $startdir/src/$pkgname-$pkgver
+ cd "$pkgname-$pkgver"
install -m755 -D xbelld ${pkgdir}/usr/bin/xbelld
install -m644 -D xbelld.1 ${pkgdir}/usr/share/man/man1/xbelld.1
}
-
-