summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Lawrence2015-07-04 14:22:21 -0400
committerScott Lawrence2015-07-04 14:22:21 -0400
commitf6f307b886f2f6dace6a446d952a606f8dc45db9 (patch)
treeea0f0f73e0200b5e0c763f8a9117cd9c3fdf8716
downloadaur-f6f307b886f2f6dace6a446d952a606f8dc45db9.tar.gz
Initial aur4 import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0fff6e022e78
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = xbelld
+ pkgdesc = X daemon that performs an action every time the bell is rung
+ pkgver = 0.3.3
+ pkgrel = 4
+ url = http://code.google.com/p/xbelld/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = xorg-server
+ depends = pkgconfig
+ depends = alsa-lib
+ source = http://xbelld.googlecode.com/files/xbelld-0.3.3.tbz2
+ md5sums = d6c9b96ac5ccd4a3072e4c9e7add6547
+
+pkgname = xbelld
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..995a3a2779d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Scott Lawrence <bytbox@gmail.com>
+# Contributor: Scott Smith <jcdenton513@gmail.com>
+# Contributor: tuxce <tuxce.net@gmail.com>
+# Contributor: teddy_beer_maniac <teddy_beer_maniac@wp.pl>
+
+pkgname=xbelld
+pkgver=0.3.3
+pkgrel=4
+pkgdesc="X daemon that performs an action every time the bell is rung"
+url="http://code.google.com/p/xbelld/"
+arch=('i686' 'x86_64')
+license=('GPL3')
+depends=('xorg-server' 'pkgconfig' 'alsa-lib')
+source=(http://xbelld.googlecode.com/files/xbelld-${pkgver}.tbz2)
+md5sums=('d6c9b96ac5ccd4a3072e4c9e7add6547')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ LDFLAGS=-lm make || return 1
+}
+
+package() {
+ cd $startdir/src/$pkgname-$pkgver
+ install -m755 -D xbelld ${pkgdir}/usr/bin/xbelld
+ install -m644 -D xbelld.1 ${pkgdir}/usr/share/man/man1/xbelld.1
+}
+
+