summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2020-05-01 20:29:35 +0000
committerAntonio Rojas2020-05-01 20:29:35 +0000
commit17d416d76aee0146b05674b0102378581cfa6b1c (patch)
tree889f946a25d181cd444a95c4afe04307450d9769
downloadaur-17d416d76aee0146b05674b0102378581cfa6b1c.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9fd5f2487966
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = xbindkeys
+ pkgdesc = Launch shell commands with your keyboard or your mouse under X
+ pkgver = 1.8.6
+ pkgrel = 3
+ url = https://www.nongnu.org/xbindkeys/xbindkeys.html
+ arch = x86_64
+ license = GPL
+ depends = libx11
+ depends = guile
+ optdepends = tk: xbindkeys_show
+ source = https://www.nongnu.org/xbindkeys/xbindkeys-1.8.6.tar.gz
+ md5sums = c6ea9db56e075dae0697497e2ed390cc
+
+pkgname = xbindkeys
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af107b6cefb2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Florian Pritz <bluewind@xinu.at>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+# Contributor: Thayer Williams <thayer@archlinux.org>
+
+pkgname=xbindkeys
+pkgver=1.8.6
+pkgrel=3
+pkgdesc="Launch shell commands with your keyboard or your mouse under X"
+arch=('x86_64')
+url="https://www.nongnu.org/xbindkeys/xbindkeys.html"
+license=('GPL')
+depends=('libx11' 'guile')
+optdepends=('tk: xbindkeys_show')
+source=(https://www.nongnu.org/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+md5sums=('c6ea9db56e075dae0697497e2ed390cc')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}