summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteve Engledow2020-07-03 12:29:58 +0100
committerSteve Engledow2020-07-03 12:29:58 +0100
commit385a5cfcb0043d865bf3f632a8c16d5e8d703380 (patch)
tree660c08fa34b3c3be8bef02f4d03a085c2b685e83
parent990e5974613e1fd1b67ba06fb74c0f919a696e72 (diff)
downloadaur-385a5cfcb0043d865bf3f632a8c16d5e8d703380.tar.gz
Add package 1
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD43
2 files changed, 35 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec3c0020078b..33724e9c8d81 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
-pkgbase = xbindkeys
- pkgdesc = Launch shell commands with your keyboard or your mouse under X
- pkgver = 1.8.7
+pkgbase = xbindkeys-git
+ pkgdesc = xbindkeys is a program that allows you to launch shell commands with your keyboard or your mouse under X Windows
+ pkgver = git
pkgrel = 1
url = https://www.nongnu.org/xbindkeys/xbindkeys.html
- arch = x86_64
- license = GPL
- depends = libx11
+ arch = any
+ license = GPL2
+ makedepends = git
depends = guile
- optdepends = tk: xbindkeys_show
- source = https://www.nongnu.org/xbindkeys/xbindkeys-1.8.7.tar.gz
- sha256sums = a29b86a8ec91d4abc83b420e547da27470847d0efe808aa6e75147aa0adb82f2
+ depends = libx11
+ optdepends = tk
+ provides = xbindkeys
+ source = git+https://git.savannah.nongnu.org/git/xbindkeys.git
+ sha256sums = SKIP
-pkgname = xbindkeys
+pkgname = xbindkeys-git
diff --git a/PKGBUILD b/PKGBUILD
index 26cd889dac47..18cb8189ed82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,30 @@
-# Maintainer: Yusuf Aktepe <yusuf@yusufaktepe.com>
-# Contributor: Florian Pritz <bluewind@xinu.at>
-# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
-# Contributor: Thayer Williams <thayer@archlinux.org>
-
-pkgname=xbindkeys
-pkgver=1.8.7
+# Maintainer: Steve Engledow <steve@offend.me.uk>
+pkgname=xbindkeys-git
+pkgver=git
pkgrel=1
-pkgdesc="Launch shell commands with your keyboard or your mouse under X"
-arch=('x86_64')
-url="https://www.nongnu.org/xbindkeys/xbindkeys.html"
-license=('GPL')
-depends=('libx11' 'guile')
-optdepends=('tk: xbindkeys_show')
-source=(https://www.nongnu.org/${pkgname}/${pkgname}-${pkgver}.tar.gz)
-sha256sums=('a29b86a8ec91d4abc83b420e547da27470847d0efe808aa6e75147aa0adb82f2')
+pkgdesc='xbindkeys is a program that allows you to launch shell commands with your keyboard or your mouse under X Windows'
+url='https://www.nongnu.org/xbindkeys/xbindkeys.html'
+arch=(any)
+license=('GPL2')
+depends=(
+ 'guile'
+ 'libx11'
+)
+optdepends=(
+ 'tk'
+)
+makedepends=('git')
+source=('git+https://git.savannah.nongnu.org/git/xbindkeys.git')
+sha256sums=('SKIP')
+provides=('xbindkeys')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix=/usr
- make
+ cd xbindkeys
+ ./configure --prefix=/usr
+ make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ cd xbindkeys
+ make install prefix="$pkgdir/usr/"
}