summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2021-06-02 17:17:22 +0800
committertaotieren2021-06-02 17:17:22 +0800
commit9fea3522c61e5d46d80090cb6c4735b53a1984e4 (patch)
tree0835b719d25b504e5fe13ffada4dd658018bae79
downloadaur-9fea3522c61e5d46d80090cb6c4735b53a1984e4.tar.gz
Update xboot
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore13
-rw-r--r--PKGBUILD61
3 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c9cddb7ea7e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = xboot-git
+ pkgdesc = The extensible bootloader for embedded system with application engine, write once, run everywhere. (Linux Sandbox for x86_64)
+ pkgver = eb5f578
+ pkgrel = 1
+ url = https://github.com/xboot/xboot
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = sdl2
+ provides = xboot-git
+ conflicts = xboot-git
+ conflicts = xboot
+ options = !strip
+ source = xboot::git+https://github.com/xboot/xboot.git
+ sha256sums = SKIP
+
+pkgname = xboot-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..25928c4443d7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,13 @@
+src
+pkg
+xboot
+*.deb
+*.rpm
+*.bz2
+*.gz
+*.zip
+*.tgz
+*.pkg.tar.xz
+*.pkg.tar.zst
+*.log
+*.png
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d13b099e2cfe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: taotieren <admin@taotieren.com>
+
+pkgname=xboot-git
+pkgver=v1.50.3008.g8934405d4
+pkgrel=1
+pkgdesc="The extensible bootloader for embedded system with application engine, write once, run everywhere. (Linux Sandbox for x86_64)"
+arch=('x86_64')
+url="https://github.com/xboot/xboot"
+license=('MIT')
+provides=(${pkgname})
+conflicts=(${pkgname} ${pkgname%-git})
+#replaces=(${pkgname})
+depends=('sdl2')
+makedepends=('git')
+backup=()
+options=('!strip')
+#install=${pkgname}.install
+source=("${pkgname%-git}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname%-git}"
+ git describe --always | sed 's|-|.|g'
+}
+
+build() {
+ cd "${srcdir}/${pkgname%-git}"
+ make CROSS_COMPILE="" PLATFORM=x64-sandbox
+}
+
+package() {
+ install -Dm0755 "${srcdir}/${pkgname%-git}/output/${pkgname%-git}" "${pkgdir}/usr/bin/${pkgname%-git}"
+ install -Dm0644 "${srcdir}/${pkgname%-git}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname%-git}/LICENSE"
+ install -Dm0644 "${srcdir}/${pkgname%-git}/developments/logo/xboot-logo.svg" "${pkgdir}/usr/share/pixmaps/${pkgname%-git}.svg"
+ install -Dm0644 "${srcdir}/${pkgname%-git}/developments/logo/xboot-logo.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/mimetypes/application-${pkgname%-git}.svg"
+
+ install -Dm0644 /dev/stdin "${pkgdir}/usr/share/applications/${pkgname%-git}.desktop" << EOF
+[Desktop Entry]
+Name=${pkgname%-git}
+Name[zh_CN]=${pkgname%-git}
+Comment=The runtime environment
+MimeType=application/${pkgname%-git};
+Exec=${pkgname%-git} %f
+Type=Application
+Categories=Development;Game;
+Terminal=false
+Icon=${pkgname%-git}
+NoDisplay=true
+Version=${pkgver}
+EOF
+
+ install -Dm0644 /dev/stdin "${pkgdir}/usr/share/mime/packages/${pkgname%-git}.xml" << EOF
+<?xml version="1.0" encoding="UTF-8"?>
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+ <mime-type type="application/x-xboot">
+ <comment>xboot</comment>
+ <glob pattern="*.x"/>
+ </mime-type>
+</mime-info>
+EOF
+}