summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCebtenzzre2022-08-04 10:49:56 -0400
committerCebtenzzre2022-08-04 11:19:33 -0400
commit3ef551cd23d7a2f4f0390dd2a99a36a918924682 (patch)
tree3a6d9926a72f2a508fbc4bbfd90636f15728b782
parent9d83917b6d4b51facd632848587ff0589488c131 (diff)
downloadaur-3ef551cd23d7a2f4f0390dd2a99a36a918924682.tar.gz
Update
Also fix URL and description
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
2 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5611fe5a8135..c50f3ef4a523 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = xboxdrv-cebtenzzre-git
- pkgver = 0.8.8.r40.gc887ab9
- pkgdesc = An XBox/XBox 360 gamepad driver - as alternative to the xpad-kernel module - with more configurability, runs in userspace and supports a multitude of controllers (Cebtenzzre's fork)
+ pkgdesc = An XBox/XBox 360 gamepad driver - extended mappings and rumble passthrough
+ pkgver = 0.8.8.r47.gaa0b96e
pkgrel = 1
- url = https://xboxdrv.gitlab.io/
+ url = https://gitlab.com/cebtenzzre/xboxdrv
arch = x86_64
arch = i686
arch = arm
@@ -19,8 +19,8 @@ pkgbase = xboxdrv-cebtenzzre-git
depends = python2
provides = xboxdrv
conflicts = xboxdrv
- source = xboxdrv-cebtenzzre-git::git+https://gitlab.com/cebtenzzre/xboxdrv.git#branch=stable
backup = etc/conf.d/xboxdrv
+ source = xboxdrv::git+https://gitlab.com/cebtenzzre/xboxdrv.git#branch=stable
source = xboxdrv.service
source = xboxdrv.conf
sha256sums = SKIP
@@ -28,4 +28,3 @@ pkgbase = xboxdrv-cebtenzzre-git
sha256sums = 68a286300d28bbfc97eb694c6cc413776f0bc16e35de6d1969f13ef1e7d1cac5
pkgname = xboxdrv-cebtenzzre-git
-
diff --git a/PKGBUILD b/PKGBUILD
index d6fc22989e32..5757de66ac36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,17 +5,17 @@
_pkgname=xboxdrv
pkgname=${_pkgname}-cebtenzzre-git
-pkgver=0.8.8.r40.gc887ab9
+pkgver=0.8.8.r47.gaa0b96e
pkgrel=1
-pkgdesc="An XBox/XBox 360 gamepad driver - as alternative to the xpad-kernel module - with more configurability, runs in userspace and supports a multitude of controllers (Cebtenzzre's fork)"
+pkgdesc="An XBox/XBox 360 gamepad driver - extended mappings and rumble passthrough"
arch=(x86_64 i686 arm armv6h armv7h aarch64)
-url="https://xboxdrv.gitlab.io/"
+url="https://gitlab.com/cebtenzzre/xboxdrv"
license=(GPL3)
depends=(libx11 dbus-glib libusb python2)
makedepends=(git scons boost)
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-source=("${pkgname}::git+https://gitlab.com/cebtenzzre/xboxdrv.git#branch=stable"
+source=("${_pkgname}::git+https://gitlab.com/cebtenzzre/xboxdrv.git#branch=stable"
'xboxdrv.service'
'xboxdrv.conf')
sha256sums=('SKIP'
@@ -25,17 +25,17 @@ sha256sums=('SKIP'
backup=(etc/conf.d/xboxdrv)
pkgver() {
- cd "$pkgname"
+ cd "$_pkgname"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$pkgname"
+ cd "$_pkgname"
sed 's|python|python2|g' -i examples/*.py
}
build() {
- cd "$pkgname"
+ cd "$_pkgname"
scons \
LINKFLAGS="${LDFLAGS}" \
CXXFLAGS="${CPPFLAGS} ${CXXFLAGS}" \
@@ -43,10 +43,10 @@ build() {
}
package() {
- cd "$pkgname"
+ cd "$_pkgname"
make PREFIX=/usr DESTDIR="$pkgdir" install
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/${_pkgname}"
install -Dm644 "${srcdir}/${_pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${_pkgname}.service"
install -Dm644 "${srcdir}/${_pkgname}.conf" "${pkgdir}/etc/conf.d/${_pkgname}"
install -Dm644 README.md NEWS PROTOCOL -t "${pkgdir}/usr/share/doc/${_pkgname}"