summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2020-04-24 14:23:11 -0400
committerEli Schwartz2020-04-24 14:23:11 -0400
commitfb82c3c455444f2e802781a138700ea068b3a1f9 (patch)
treee1df03061172d228e65e22efec85cf4a2ee89e4b
parentccacc9aa394af5cd37950f9084af670e5828e67e (diff)
downloadaur-xbps.tar.gz
upgpkg: xbps 0.59.1-1
- upstream release (err, a few of them) - Use the default dbdir, because it makes little sense to build a tool for interacting with e.g. voidlinux chroots or bootstrapping... and then use an incompatible database path. This is obviously not pacman, and I'm unsure why the previous maintainer modeled it after pacman's layout. :/ - Switch to latest openssl, since xbps supports it now. - Fix license file rename.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 92a88a23f173..f7512f876494 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xbps
pkgdesc = The X Binary Package System from Void Linux. Don't use it instead of Arch's 'pacman'.
- pkgver = 0.53
+ pkgver = 0.59.1
pkgrel = 1
url = https://github.com/void-linux/xbps
arch = i686
@@ -8,9 +8,9 @@ pkgbase = xbps
license = BSD
depends = ca-certificates
depends = libarchive
- depends = openssl-1.0
- source = xbps-0.53.tar.gz::https://github.com/void-linux/xbps/archive/0.53.tar.gz
- sha256sums = 360b3149141fec46dd6da9019605bcee48ee4d29bffe5aa47a9fd5fa68ccd5f4
+ depends = openssl
+ source = xbps-0.59.1.tar.gz::https://github.com/void-linux/xbps/archive/0.59.1.tar.gz
+ sha256sums = 0cbd8d5f23a62047c75974bca21da9f004a94efffd7f37c68562a8dbc869fb2a
pkgname = xbps
diff --git a/PKGBUILD b/PKGBUILD
index 24c017388557..462adc770b48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,22 @@
# All my PKGBUILDs are managed at https://github.com/eli-schwartz/pkgbuilds
pkgname=xbps
-pkgver=0.53
+pkgver=0.59.1
pkgrel=1
pkgdesc="The X Binary Package System from Void Linux. Don't use it instead of Arch's 'pacman'."
arch=('i686' 'x86_64')
url="https://github.com/void-linux/xbps"
license=('BSD')
-depends=('ca-certificates' 'libarchive' 'openssl-1.0')
+depends=('ca-certificates' 'libarchive' 'openssl')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=('360b3149141fec46dd6da9019605bcee48ee4d29bffe5aa47a9fd5fa68ccd5f4')
+sha256sums=('0cbd8d5f23a62047c75974bca21da9f004a94efffd7f37c68562a8dbc869fb2a')
build() {
cd "${srcdir}"/${pkgname}-${pkgver}
- export PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig
+
./configure \
--prefix=/usr \
- --sysconfdir=/etc \
- --dbdir=/var/lib/xbps
+ --sysconfdir=/etc
sed -i '/-Werror/d' config.mk
make
@@ -27,7 +26,8 @@ build() {
package() {
cd "${srcdir}"/${pkgname}-${pkgver}
+
make DESTDIR="${pkgdir}" install
- install -Dm644 COPYING "${pkgdir}"/usr/share/licenses/${pkgname}/COPYING
- install -Dm644 COPYING.3RDPARTY "${pkgdir}"/usr/share/licenses/${pkgname}/COPYING.3RDPARTY
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm644 LICENSE.3RDPARTY "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE.3RDPARTY
}