summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2019-01-07 22:26:58 -0600
committerDan Beste2019-01-07 22:26:58 -0600
commit584abb876eac84bacb09ad2f13b9f7d8bf89a1f0 (patch)
tree776c315119c0842f64032a59567865abcf01a050
parent9ec3347340e6aa4059897e91dcc35879f5829b8e (diff)
downloadaur-584abb876eac84bacb09ad2f13b9f7d8bf89a1f0.tar.gz
PKGBUILD cleanup
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD44
2 files changed, 19 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 850c9b309e7a..8af2bc89a58e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = xcb-util-cursor-git
- pkgdesc = XCB cursor management library
+ pkgdesc = XCB cursor library
pkgver = 0.1.3.r1.g947eaba
pkgrel = 1
url = https://xcb.freedesktop.org/
- arch = i686
arch = x86_64
license = MIT
makedepends = git
@@ -14,8 +13,8 @@ pkgbase = xcb-util-cursor-git
depends = xcb-util-image
provides = xcb-util-cursor
conflicts = xcb-util-cursor
- source = git+http://anongit.freedesktop.org/git/xcb/util-cursor.git
- source = m4::git+https://anongit.freedesktop.org/git/xcb/util-common-m4.git
+ source = git+https://anongit.freedesktop.org/git/xcb/util-cursor.git
+ source = git+https://anongit.freedesktop.org/git/xcb/util-common-m4.git
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 5b699a56468f..d6045d9d596c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,10 @@
-# Maintainer: Leonard König <leonard dot r dot koenig at googlemail dot com>
+# Maintainer: Dan Beste <dan.ray.beste@gmail.com>
pkgname='xcb-util-cursor-git'
-_pkgname='util-cursor'
pkgver=0.1.3.r1.g947eaba
pkgrel=1
-pkgdesc='XCB cursor management library'
-arch=('i686' 'x86_64')
+pkgdesc='XCB cursor library'
+arch=('x86_64')
url='https://xcb.freedesktop.org/'
license=('MIT')
depends=('libxcb' 'xcb-util-renderutil' 'xcb-util-image')
@@ -13,49 +12,38 @@ makedepends=('git' 'xorg-util-macros' 'gperf')
provides=("${pkgname/-git/}")
conflicts=("${pkgname/-git/}")
source=(
- "git+http://anongit.freedesktop.org/git/xcb/${_pkgname}.git"
- 'm4::git+https://anongit.freedesktop.org/git/xcb/util-common-m4.git'
-)
-sha256sums=(
- 'SKIP'
- 'SKIP'
+ 'git+https://anongit.freedesktop.org/git/xcb/util-cursor.git'
+ 'git+https://anongit.freedesktop.org/git/xcb/util-common-m4.git'
)
+sha256sums=('SKIP' 'SKIP')
pkgver() {
- cd "${_pkgname}"
+ cd util-cursor
git describe --long --tags \
- | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ | sed 's/-/.r/;s/-/./'
}
prepare() {
- cd "${_pkgname}"
-
- local submodules=(
- 'm4'
- )
+ cd util-cursor
- for submodule in "${submodules[@]}"; do
- git submodule init "${submodule}"
- git config "submodule.${submodule}.url" "${srcdir}/${submodule}"
- git submodule update "${submodule}"
- done
+ git submodule init "m4"
+ git config "submodule.m4.url" "../util-common-m4"
+ git submodule update "m4"
}
build() {
- cd "${_pkgname}"
+ cd util-cursor
./autogen.sh --prefix=/usr
make
}
package() {
- cd "${_pkgname}"
+ cd util-cursor
- install -d "${pkgdir}/usr/share/licenses/${pkgname}/"
-
- make DESTDIR="${pkgdir}" install
- install -m 644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ DESTDIR="${pkgdir}" make install
+ install -Dm 644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
# vim: ts=2 sw=2 et: