summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShiv Upadhyay2021-02-15 19:47:14 -0500
committerShiv Upadhyay2021-02-15 19:47:14 -0500
commit25c19b17f1ef7b55bda3a2bb059e40e09a34d480 (patch)
tree20404a2e27297b09fab115069b7d191b6c3e7e68
downloadaur-25c19b17f1ef7b55bda3a2bb059e40e09a34d480.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD37
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c89472e8beec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = xcfun-git
+ pkgdesc = Exchange-Correlation functionals with arbitrary order derivatives
+ pkgver = 2.1.1.r1.gf87ca0e
+ pkgrel = 1
+ url = http://dftlibs.org/xcfun/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ provides = xcfun
+ conflicts = xcfun
+ source = xcfun-git::git+https://github.com/dftlibs/xcfun.git
+ md5sums = SKIP
+
+pkgname = xcfun-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..304e7dc72ca6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Jia Li <lijia1608@gmail.com>
+pkgname=xcfun-git
+_pkgname=xcfun
+pkgver=2.1.1.r1.gf87ca0e
+pkgrel=1
+pkgdesc="Exchange-Correlation functionals with arbitrary order derivatives"
+arch=(i686 x86_64)
+url="http://dftlibs.org/xcfun/"
+license=('GPL3')
+makedepends=(git cmake)
+provides=(xcfun)
+conflicts=(xcfun-pyscf)
+conflicts=(xcfun)
+source=($pkgname::git+https://github.com/dftlibs/xcfun.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=RELEASE -DBUILD_SHARED_LIBS=1 \
+ -DXC_MAX_ORDER=3 -DXCFUN_ENABLE_TESTS=0 \
+ -DXCFUN_PYTHON_INTERFACE=1 \
+ -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ ..
+ make -j`getconf _NPROCESSORS_ONLN`
+}
+
+package() {
+ cd "$pkgname/build"
+ make DESTDIR="$pkgdir/" install
+}