summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Kitsinger (SwooshyCueb)2020-09-01 15:33:19 -0500
committerMarkus Kitsinger (SwooshyCueb)2020-09-01 15:33:19 -0500
commit7451b7bf2351a1e643bcc717fe8574ccf55fea24 (patch)
tree98cc8d6c1b9ef9e9447764364f2cdfeb2ca4d4ae
parente0c191cb7b410dc4b688a2cbd99023648d542d9d (diff)
downloadaur-7451b7bf2351a1e643bcc717fe8574ccf55fea24.tar.gz
Move pkgconfig to proper location
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dfdcc8425f28..fe35b0a15b0a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xchat-se
pkgdesc = An xchat fork with a few different features
pkgver = 1.2.21
- pkgrel = 3
+ pkgrel = 4
url = https://xchat.servx.ru/
arch = x86_64
depends = gtk2
diff --git a/PKGBUILD b/PKGBUILD
index 447002d30daf..6dfdb3436d0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=xchat-se
pkgver=1.2.21
-pkgrel=3
+pkgrel=4
pkgdesc="An xchat fork with a few different features"
arch=('x86_64')
#license=('unknown')
@@ -26,11 +26,16 @@ optdepends=('enchant: for spell checking support'
'python2: for python plugin')
package() {
- cd "${srcdir}"
+ cd "${pkgdir}"
- tar -xJf data.tar.xz -C "${pkgdir}"
+ bsdtar xf "${srcdir}/data.tar.xz"
- # Remove extra keywords line from desktop file
- sed -i '0,/^Keywords=.\+/! {/^Keywords=.\+/d}' "${pkgdir}/usr/share/applications/xchat.desktop"
+ # Move pkgconfig to proper location
+ mv "usr/lib/x86_64-linux-gnu/pkgconfig" "usr/lib/pkgconfig"
+ # We leave the xchat/plugins folder where it is
+ # because the path is hard-coded in the xchat binary
+ # Remove extra keywords line from desktop file
+ # We probably don't need this any more but I'm gonna leave it here anyway ~MK
+ sed -i '0,/^Keywords=.\+/! {/^Keywords=.\+/d}' "usr/share/applications/xchat.desktop"
}