summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAtifChy2021-08-17 22:36:57 +0600
committerAtifChy2021-08-17 22:36:57 +0600
commit60cdb6eaddc0b62716287f7e92802f15abee9e37 (patch)
tree49be3754021b441330ab183390c3eb5b777a0b0e
parentf4180367bfcdad1d96696a9a4ba0ec8f3d6d93fb (diff)
downloadaur-60cdb6eaddc0b62716287f7e92802f15abee9e37.tar.gz
removed the patch file. it's not needed anymore.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
-rw-r--r--cargo_fix.patch159
3 files changed, 6 insertions, 175 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 606de553454a..a4e8c999de6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xcolor-git
pkgdesc = Lightweight color picker for X11
- pkgver = 0.5.0.100.g0e99e67
- pkgrel = 2
+ pkgver = 0.5.0.101.gf23338a
+ pkgrel = 1
url = https://github.com/Soft/xcolor
arch = x86_64
license = MIT
@@ -10,8 +10,6 @@ pkgbase = xcolor-git
makedepends = python
depends = libxcb
source = xcolor-git::git+https://github.com/Soft/xcolor.git
- source = cargo_fix.patch
sha256sums = SKIP
- sha256sums = 58575b5e08ded6af6331f9fd1e22023b7479905f9a7781d99507d33559ee25c9
pkgname = xcolor-git
diff --git a/PKGBUILD b/PKGBUILD
index 574ddd90cbcd..3249a86efa90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,21 @@
# Maintainer: Atif Chowdhury <iftakhar.awal@gmail.com>
pkgname=xcolor-git
-pkgver=0.5.0.100.g0e99e67
-pkgrel=2
+pkgver=0.5.0.101.gf23338a
+pkgrel=1
pkgdesc="Lightweight color picker for X11"
arch=(x86_64)
url="https://github.com/Soft/xcolor"
license=(MIT)
depends=("libxcb")
makedepends=("rust" "cargo" "python")
-source=("$pkgname::git+https://github.com/Soft/xcolor.git" "cargo_fix.patch")
-sha256sums=('SKIP' '58575b5e08ded6af6331f9fd1e22023b7479905f9a7781d99507d33559ee25c9')
+source=("$pkgname::git+https://github.com/Soft/xcolor.git")
+sha256sums=('SKIP')
pkgver() {
cd "$pkgname"
echo "$(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2|cut -d\- -f1).$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "$pkgname"
- _commit=$(git rev-parse HEAD | cut -c1-7)
- if [ "${_commit}" = "0e99e67" ]; then
- patch -p1 < $startdir/cargo_fix.patch
- fi
-}
-
build() {
cd "$pkgname"
cargo build --release
diff --git a/cargo_fix.patch b/cargo_fix.patch
deleted file mode 100644
index 6a68e5b1e0c6..000000000000
--- a/cargo_fix.patch
+++ /dev/null
@@ -1,159 +0,0 @@
-diff --git a/Cargo.lock b/Cargo.lock
-index e0fb2e8..373f78d 100644
---- a/Cargo.lock
-+++ b/Cargo.lock
-@@ -11,9 +11,9 @@ dependencies = [
-
- [[package]]
- name = "anyhow"
--version = "1.0.34"
-+version = "1.0.41"
- source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "bf8dcb5b4bbaa28653b647d8c77bd4ed40183b48882e130c1f1ffb73de069fd7"
-+checksum = "15af2628f6890fe2609a3b91bef4c83450512802e59489f9c1cb1fa5df064a61"
-
- [[package]]
- name = "arrayvec"
-@@ -40,9 +40,9 @@ checksum = "cf1de2fe8c75bc145a2f577add951f8134889b4795d47466a54a5c846d691693"
-
- [[package]]
- name = "bitvec"
--version = "0.19.4"
-+version = "0.19.5"
- source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "a7ba35e9565969edb811639dbebfe34edc0368e472c5018474c8eb2543397f81"
-+checksum = "8942c8d352ae1838c9dda0b0ca2ab657696ef2232a20147cf1b30ae1a9cb4321"
- dependencies = [
- "funty",
- "radium",
-@@ -52,9 +52,9 @@ dependencies = [
-
- [[package]]
- name = "cc"
--version = "1.0.62"
-+version = "1.0.68"
- source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "f1770ced377336a88a67c473594ccc14eca6f4559217c34f64aac8f83d641b40"
-+checksum = "4a72c244c1ff497a746a7e1fb3d14bd08420ecda70c8f25c7112f2781652d787"
-
- [[package]]
- name = "cfg-if"
-@@ -62,6 +62,12 @@ version = "0.1.10"
- source = "registry+https://github.com/rust-lang/crates.io-index"
- checksum = "4785bdd1c96b2a846b2bd7cc02e86b6b3dbf14e7e53446c4f54c92a361040822"
-
-+[[package]]
-+name = "cfg-if"
-+version = "1.0.0"
-+source = "registry+https://github.com/rust-lang/crates.io-index"
-+checksum = "baf1de4339761588bc0619e3cbc0120ee582ebb74b53b4efbf79117bd2da40fd"
-+
- [[package]]
- name = "clap"
- version = "2.33.3"
-@@ -79,15 +85,15 @@ dependencies = [
-
- [[package]]
- name = "funty"
--version = "1.0.1"
-+version = "1.1.0"
- source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "0ba62103ce691c2fd80fbae2213dfdda9ce60804973ac6b6e97de818ea7f52c8"
-+checksum = "fed34cd105917e91daa4da6b3728c47b068749d6a62c59811f06ed2ac71d9da7"
-
- [[package]]
- name = "hermit-abi"
--version = "0.1.17"
-+version = "0.1.19"
- source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "5aca5565f760fb5b220e499d72710ed156fdb74e631659e99377d9ebfbd13ae8"
-+checksum = "62b467343b94ba476dcb2500d242dadbb39557df889310ac77c5d99100aaac33"
- dependencies = [
- "libc",
- ]
-@@ -100,30 +106,30 @@ checksum = "e2abad23fbc42b3700f2f279844dc832adb2b2eb069b2df918f455c4e18cc646"
-
- [[package]]
- name = "lexical-core"
--version = "0.7.4"
-+version = "0.7.6"
- source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "db65c6da02e61f55dae90a0ae427b2a5f6b3e8db09f58d10efab23af92592616"
-+checksum = "6607c62aa161d23d17a9072cc5da0be67cdfc89d3afb1e8d9c842bebc2525ffe"
- dependencies = [
- "arrayvec",
- "bitflags",
-- "cfg-if",
-+ "cfg-if 1.0.0",
- "ryu",
- "static_assertions",
- ]
-
- [[package]]
- name = "libc"
--version = "0.2.80"
-+version = "0.2.97"
- source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "4d58d1b70b004888f764dfbf6a26a3b0342a1632d33968e4a179d8011c760614"
-+checksum = "12b8adadd720df158f4d70dfe7ccc6adb0472d7c55ca83445f6a5ab3e36f8fb6"
-
- [[package]]
- name = "log"
--version = "0.4.11"
-+version = "0.4.14"
- source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "4fabed175da42fed1fa0746b0ea71f412aa9d35e76e95e59b192c64b9dc2bf8b"
-+checksum = "51b9bbe6c47d51fc3e1a9b945965946b4c44142ab8792c50835a980d362c2710"
- dependencies = [
-- "cfg-if",
-+ "cfg-if 1.0.0",
- ]
-
- [[package]]
-@@ -140,18 +146,19 @@ checksum = "50e4785f2c3b7589a0d0c1dd60285e1188adac4006e8abd6dd578e1567027363"
- dependencies = [
- "bitflags",
- "cc",
-- "cfg-if",
-+ "cfg-if 0.1.10",
- "libc",
- "void",
- ]
-
- [[package]]
- name = "nom"
--version = "6.0.0"
-+version = "6.2.1"
- source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "4489ccc7d668957ddf64af7cd027c081728903afa6479d35da7e99bf5728f75f"
-+checksum = "9c5c51b9083a3c620fa67a2a635d1ce7d95b897e957d6b28ff9a5da960a103a6"
- dependencies = [
- "bitvec",
-+ "funty",
- "lexical-core",
- "memchr",
- "version_check",
-@@ -189,9 +196,9 @@ checksum = "8ea5119cdb4c55b55d432abb513a0429384878c15dde60cc77b1c99de1a95a6a"
-
- [[package]]
- name = "tap"
--version = "1.0.0"
-+version = "1.0.1"
- source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "36474e732d1affd3a6ed582781b3683df3d0563714c59c39591e8ff707cf078e"
-+checksum = "55937e1799185b12863d447f42597ed69d9928686b8d88a1df17376a097d8369"
-
- [[package]]
- name = "textwrap"
-@@ -216,9 +223,9 @@ checksum = "f1bddf1187be692e79c5ffeab891132dfb0f236ed36a43c7ed39f1165ee20191"
-
- [[package]]
- name = "version_check"
--version = "0.9.2"
-+version = "0.9.3"
- source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "b5a972e5669d67ba988ce3dc826706fb0a8b01471c088cb0b6110b805cc36aed"
-+checksum = "5fecdca9a5291cc2b8dcf7dc02453fee791a280f3743cb0905f8822ae463b3fe"
-
- [[package]]
- name = "void"