summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAtifChy2021-08-07 13:56:38 +0600
committerAtifChy2021-08-07 13:56:38 +0600
commitf4180367bfcdad1d96696a9a4ba0ec8f3d6d93fb (patch)
treed10b321e5b8778f2a75b931961bfda05a174baf9
parent2d51b61be6e5b38a75e3eac45b6dfd1c293c12c5 (diff)
downloadaur-f4180367bfcdad1d96696a9a4ba0ec8f3d6d93fb.tar.gz
use a simpler command to get commit
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f78b43564a7d..606de553454a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xcolor-git
pkgdesc = Lightweight color picker for X11
pkgver = 0.5.0.100.g0e99e67
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Soft/xcolor
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 71e4b69c0941..574ddd90cbcd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Atif Chowdhury <iftakhar.awal@gmail.com>
pkgname=xcolor-git
pkgver=0.5.0.100.g0e99e67
-pkgrel=1
+pkgrel=2
pkgdesc="Lightweight color picker for X11"
arch=(x86_64)
url="https://github.com/Soft/xcolor"
@@ -17,9 +17,9 @@ pkgver() {
}
prepare() {
- _get_commit=$(git ls-remote https://github.com/Soft/xcolor.git HEAD | cut -f1)
- if [ ${_get_commit} = "0e99e67cd37000bf563aa1e89faae796ec25f163" ]; then
- cd "$pkgname"
+ cd "$pkgname"
+ _commit=$(git rev-parse HEAD | cut -c1-7)
+ if [ "${_commit}" = "0e99e67" ]; then
patch -p1 < $startdir/cargo_fix.patch
fi
}