summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManoel Brunnen2016-09-07 19:28:19 +0200
committerManoel Brunnen2016-09-07 19:28:19 +0200
commitb32b8d30c69a5262412afc2ec2d022f8a5472742 (patch)
tree52ac69bedfe124c57302f8d272e7999f7710e3a5
downloadaur-b32b8d30c69a5262412afc2ec2d022f8a5472742.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD50
-rw-r--r--fix.patch11
-rw-r--r--xctu.desktop9
5 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..efbfbd6c1875
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = xctu
+ pkgdesc = Next Generation Configuration Platform for XBee/RF Solutions.
+ pkgver = 6.3.2
+ pkgrel = 2
+ url = http://www.digi.com/products/xbee-rf-solutions/xctu-software/xctu
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = java-runtime-common
+ options = !strip
+ source = http://ftp1.digi.com/support/utilities/40002881_D.run
+ source = xctu.desktop
+ source = fix.patch
+ md5sums = 47cfcde687bf56196de66476fe8bca27
+ md5sums = 53dff8062eaad0249252f0bb93ad7404
+ md5sums = 1e0ebe726f6d5304091d6e10d01de7be
+
+pkgname = xctu
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6803660e373a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/src
+/pkg
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb8824737a44
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Manoel Brunnen <manoel.brunnen@gmail.com>
+
+pkgname=xctu
+pkgver=6.3.2
+pkgrel=2
+pkgdesc="Next Generation Configuration Platform for XBee/RF Solutions."
+arch=('i686' 'x86_64')
+url="http://www.digi.com/products/xbee-rf-solutions/xctu-software/xctu"
+license=('custom')
+depends=('java-runtime-common')
+options=('!strip')
+# install=$pkgname.install
+if [[ $CARCH == 'i686' ]]; then
+ _setup_file=40002880_D.run
+ md5sums=('97372b7aabdc3e25897726439373f798')
+elif [[ $CARCH == 'x86_64' ]]; then
+ _setup_file=40002881_D.run
+ md5sums=('47cfcde687bf56196de66476fe8bca27')
+fi
+source=("http://ftp1.digi.com/support/utilities/$_setup_file"
+ 'xctu.desktop'
+ 'fix.patch')
+md5sums+=('53dff8062eaad0249252f0bb93ad7404'
+ '1e0ebe726f6d5304091d6e10d01de7be')
+noextract=()
+
+prepare() {
+ chmod u+x $_setup_file
+ # ./$_setup_file --prefix $srcdir --mode unattended --unattendedmodeui none
+ # prefix option not working:
+ printf "\n\n\n\n\ny\n\n$srcdir\n\n\nn\nn\n" | ./$_setup_file --mode text || true
+ mv $srcdir/XCTU-NG $srcdir/$pkgname
+ # XCTU wants to write a version file in the installation directory at first startup
+ echo $pkgver > $srcdir/$pkgname/version.txt
+ patch -p1 -N < $srcdir/fix.patch
+}
+
+package() {
+ install -d $pkgdir/opt
+ cp -a $srcdir/$pkgname $pkgdir/opt/$pkgname
+ install -Dm644 $srcdir/$pkgname/doc/License_Agreements.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
+
+ # Launcher
+ install -Dm755 $srcdir/$pkgname/launcher $pkgdir/usr/bin/$pkgname
+
+ # Desktop file
+ install -Dm644 $srcdir/$pkgname/icon.xpm $pkgdir/usr/share/icons/hicolor/256x256/apps/xctu.xpm
+ install -Dm644 $srcdir/xctu.desktop $pkgdir/usr/share/applications/xctu.desktop
+}
+# vim:set ft=sh:
diff --git a/fix.patch b/fix.patch
new file mode 100644
index 000000000000..c8c79e43958e
--- /dev/null
+++ b/fix.patch
@@ -0,0 +1,11 @@
+diff -Naur a/xctu/configuration/config.ini b/xctu/configuration/config.ini
+--- a/xctu/configuration/config.ini 2016-09-07 19:05:45.151674115 +0200
++++ b/xctu/configuration/config.ini 2016-09-07 19:06:45.132030148 +0200
+@@ -9,5 +9,6 @@
+ osgi.splashPath=platform\:/base/plugins/com.digi.xctung
+ osgi.framework.extensions=
+ osgi.bundles.defaultStartLevel=4
+-eclipse.p2.data.area=@config.dir/../p2
++eclipse.p2.data.area.ReadOnly=@config.dir/../p2
+ eclipse.application=com.digi.xctung.application
++osgi.instance.area=@user.home/.config/xctu
diff --git a/xctu.desktop b/xctu.desktop
new file mode 100644
index 000000000000..cbbe7cf866f2
--- /dev/null
+++ b/xctu.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Version=6.3.2.3
+Name=XCTU
+Comment=Configuration and Test Utiity
+Icon=xctu.xpm
+Exec=env UBUNTU_MENUPROXY=0 GTK2_RC_FILES=$GTK2_RC_FILES:/opt/xctu/.gtkrc-eclipse /opt/xctu/app
+Terminal=false
+Path=/opt/xctu