summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGötz Christ2021-10-03 13:16:09 -0500
committerGötz Christ2021-10-03 13:18:21 -0500
commit6adeb676d13da151049c05b1d42a0977db20cebf (patch)
tree8005f7fd2eb5aad921f701e0c6b9c6f134c0927e
parent2ecba37653c9cda867464e31411130c9c1e26fdf (diff)
downloadaur-6adeb676d13da151049c05b1d42a0977db20cebf.tar.gz
Update to 5.22.5
Update Makefile
-rw-r--r--.SRCINFO11
-rw-r--r--Makefile26
-rw-r--r--PKGBUILD8
3 files changed, 30 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d20e2e3dbc6..dda08189ceed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = xcursor-breeze
- pkgdesc = Breeze cursor theme (KDE Plasma 5). This package is for usage in non-KDE Plasma desktops.
- pkgver = 5.21.1
+ pkgdesc = KDE Plasma 5 'Breeze' cursor theme. This package is for usage in non-KDE Plasma desktops.
+ pkgver = 5.22.5
pkgrel = 1
epoch = 1
- url = https://www.kde.org
+ url = https://kde.org/plasma-desktop
arch = any
license = GPL
depends = libxcursor
conflicts = breeze
- source = http://download.kde.org/stable/plasma/5.21.1/breeze-5.21.1.tar.xz
- sha256sums = 65d95562489f2dc66240b690882f467a4a7990885fd7185337a5006709d3b7f5
+ source = http://download.kde.org/stable/plasma/5.22.5/breeze-5.22.5.tar.xz
+ sha256sums = e3fc4ca04cc0df694ab90fa4f9e8ca72512adae2c0320ce3f9702dddda029426
pkgname = xcursor-breeze
-
diff --git a/Makefile b/Makefile
index 8a02706c1167..8de6b1d0dc69 100644
--- a/Makefile
+++ b/Makefile
@@ -1,28 +1,44 @@
-all: clean build git install
+.PHONY: all
+all: build git install
+.PHONY: clean
clean:
rm -r src pkg || true
+.PHONY: geninteg
geninteg:
sed -i '/.*sums=(/,$$d' PKGBUILD
makepkg --geninteg >> PKGBUILD
+.PHONY: srcinfo
srcinfo:
makepkg --printsrcinfo > .SRCINFO
+.PHONY: makepkg
makepkg:
makepkg -s
+.PHONY: build
build: geninteg srcinfo makepkg
+.PHONY: git
git: git_add git_commit
+.PHONY: git_add
git_add:
- git add PKGBUILD .SRCINFO
+ git add PKGBUILD .SRCINFO Makefile
-git_commit: VERSION = $(shell grep pkgver .SRCINFO | cut -d '=' -f 2 | tr -d '[:space:]')
+.PHONY: git_commit
+git_commit: VERSION = "$(shell grep pkgver .SRCINFO | cut -d '=' -f 2 | xargs)"
+git_commit: GIT_STATUS = "$(shell git status --porcelain)"
git_commit:
- git commit -m "Update to ${VERSION}"
+ [ -n ${GIT_STATUS} ] && git commit -m "Update to ${VERSION}"
+.PHONY: install
install:
- makepkg --install
+ makepkg --repackage --install --force
+
+.PHONY: open
+open: URL = "$(shell grep url .SRCINFO | cut -d '=' -f 2 | xargs)"
+open:
+ xdg-open $(URL)
diff --git a/PKGBUILD b/PKGBUILD
index 13622939d226..2ae8308b343c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,11 @@
pkgname=xcursor-breeze
epoch=1
-pkgver=5.21.1
+pkgver=5.22.5
pkgrel=1
-pkgdesc="Breeze cursor theme (KDE Plasma 5). This package is for usage in non-KDE Plasma desktops."
+pkgdesc="KDE Plasma 5 'Breeze' cursor theme. This package is for usage in non-KDE Plasma desktops."
arch=('any')
-url="https://www.kde.org"
+url="https://kde.org/plasma-desktop"
license=('GPL')
depends=('libxcursor')
conflicts=('breeze')
@@ -20,4 +20,4 @@ package() {
cp -r "$srcdir"/breeze-${pkgver}/cursors/Breeze_Snow/Breeze_Snow/ "$pkgdir"/usr/share/icons/
}
-sha256sums=('65d95562489f2dc66240b690882f467a4a7990885fd7185337a5006709d3b7f5')
+sha256sums=('e3fc4ca04cc0df694ab90fa4f9e8ca72512adae2c0320ce3f9702dddda029426')