summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGötz Christ2020-06-16 09:24:01 -0500
committerGötz Christ2020-06-16 09:28:03 -0500
commit8b13174fb8e5ca30f463201aaec1a45c9b1e7cbf (patch)
treed3be5e176ccb0d13bfc90fb262201b94c1fe01f3
parentf620c00cb82f416d0cc6432d2a0576e8181b5277 (diff)
downloadaur-8b13174fb8e5ca30f463201aaec1a45c9b1e7cbf.tar.gz
Add Makefile
Handy to automate future updates Usage: make all No resulting package changes, so no pkgrel bump needed.
-rw-r--r--.SRCINFO2
-rw-r--r--Makefile28
-rw-r--r--PKGBUILD4
3 files changed, 32 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9cc12e697623..3d287444d52f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,7 +9,7 @@ pkgbase = xcursor-breeze
depends = libxcursor
conflicts = breeze
source = http://download.kde.org/stable/plasma/5.19.1/breeze-5.19.1.tar.xz
- sha1sums = cd033a1a35212d6db198fe748e8466713a6c1b2e
+ sha256sums = b93d34c0d2b7a47440c0c324e0dacd23cfa82cba2929d568cc9091910bb1ce6e
pkgname = xcursor-breeze
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..d84ed221f62e
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,28 @@
+all: clean build git install
+
+clean:
+ rm -r src pkg || true
+
+geninteg:
+ sed -i '/sums=(/,$$d' PKGBUILD
+ makepkg --geninteg >> PKGBUILD
+
+srcinfo:
+ makepkg --printsrcinfo > .SRCINFO
+
+makepkg:
+ makepkg -s
+
+build: geninteg srcinfo makepkg
+
+git: git_add git_commit
+
+git_add:
+ git add PKGBUILD .SRCINFO
+
+git_commit: VERSION = $(shell grep pkgver .SRCINFO | cut -d '=' -f 2 | tr -d '[:space:]')
+git_commit:
+ git commit -m "Update to ${VERSION}"
+
+install:
+ makepkg --install
diff --git a/PKGBUILD b/PKGBUILD
index 1afed70027da..9f8914153c6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,9 +13,11 @@ license=('GPL')
depends=('libxcursor')
conflicts=('breeze')
source=("http://download.kde.org/stable/plasma/${pkgver}/breeze-${pkgver}.tar.xz")
-sha1sums=('cd033a1a35212d6db198fe748e8466713a6c1b2e')
+
package() {
install -dm755 "$pkgdir"/usr/share/icons/
cp -r "$srcdir"/breeze-${pkgver}/cursors/Breeze/Breeze/ "$pkgdir"/usr/share/icons/
cp -r "$srcdir"/breeze-${pkgver}/cursors/Breeze_Snow/Breeze_Snow/ "$pkgdir"/usr/share/icons/
}
+
+sha256sums=('b93d34c0d2b7a47440c0c324e0dacd23cfa82cba2929d568cc9091910bb1ce6e')