summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGötz2023-07-05 09:54:52 -0500
committerGötz2023-07-05 09:54:52 -0500
commit9c71478ad09c6e36c999899fad91d0eea7161007 (patch)
treeb79e56c59bb45803005ce7c01d20cda2b88be843
parent6adeb676d13da151049c05b1d42a0977db20cebf (diff)
downloadaur-9c71478ad09c6e36c999899fad91d0eea7161007.tar.gz
Update to 5.27.6
-rw-r--r--.SRCINFO6
-rw-r--r--Makefile18
-rw-r--r--PKGBUILD4
3 files changed, 20 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dda08189ceed..27b20917a29a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xcursor-breeze
pkgdesc = KDE Plasma 5 'Breeze' cursor theme. This package is for usage in non-KDE Plasma desktops.
- pkgver = 5.22.5
+ pkgver = 5.27.6
pkgrel = 1
epoch = 1
url = https://kde.org/plasma-desktop
@@ -8,7 +8,7 @@ pkgbase = xcursor-breeze
license = GPL
depends = libxcursor
conflicts = breeze
- source = http://download.kde.org/stable/plasma/5.22.5/breeze-5.22.5.tar.xz
- sha256sums = e3fc4ca04cc0df694ab90fa4f9e8ca72512adae2c0320ce3f9702dddda029426
+ source = http://download.kde.org/stable/plasma/5.27.6/breeze-5.27.6.tar.xz
+ sha256sums = 5d9a8d7e5b061ce4183c4f842b0e82e6132b6c8e7ebc2c1d579baa066ffa6c6c
pkgname = xcursor-breeze
diff --git a/Makefile b/Makefile
index 8de6b1d0dc69..6073b72eb45d 100644
--- a/Makefile
+++ b/Makefile
@@ -1,3 +1,9 @@
+.SHELL = /usr/bin/env bash
+
+NAME = "$(shell grep -m 1 pkgname .SRCINFO | cut -d '=' -f 2 | xargs)"
+URL = "$(shell grep url .SRCINFO | cut -d '=' -f 2 | xargs)"
+VERSION = "$(shell grep pkgver .SRCINFO | cut -d '=' -f 2 | xargs)"
+
.PHONY: all
all: build git install
@@ -16,7 +22,7 @@ srcinfo:
.PHONY: makepkg
makepkg:
- makepkg -s
+ makepkg --syncdeps --force
.PHONY: build
build: geninteg srcinfo makepkg
@@ -29,7 +35,6 @@ git_add:
git add PKGBUILD .SRCINFO Makefile
.PHONY: git_commit
-git_commit: VERSION = "$(shell grep pkgver .SRCINFO | cut -d '=' -f 2 | xargs)"
git_commit: GIT_STATUS = "$(shell git status --porcelain)"
git_commit:
[ -n ${GIT_STATUS} ] && git commit -m "Update to ${VERSION}"
@@ -39,6 +44,13 @@ install:
makepkg --repackage --install --force
.PHONY: open
-open: URL = "$(shell grep url .SRCINFO | cut -d '=' -f 2 | xargs)"
open:
xdg-open $(URL)
+
+.PHONY: run
+run:
+ env $(NAME)
+
+.PHONY: test
+test:
+ env $(NAME) --version
diff --git a/PKGBUILD b/PKGBUILD
index 2ae8308b343c..44aebd42a676 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=xcursor-breeze
epoch=1
-pkgver=5.22.5
+pkgver=5.27.6
pkgrel=1
pkgdesc="KDE Plasma 5 'Breeze' cursor theme. This package is for usage in non-KDE Plasma desktops."
arch=('any')
@@ -20,4 +20,4 @@ package() {
cp -r "$srcdir"/breeze-${pkgver}/cursors/Breeze_Snow/Breeze_Snow/ "$pkgdir"/usr/share/icons/
}
-sha256sums=('e3fc4ca04cc0df694ab90fa4f9e8ca72512adae2c0320ce3f9702dddda029426')
+sha256sums=('5d9a8d7e5b061ce4183c4f842b0e82e6132b6c8e7ebc2c1d579baa066ffa6c6c')