summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAkatsuki Rui2023-07-05 10:34:08 +0800
committerAkatsuki Rui2023-07-05 10:34:08 +0800
commitcae0b887516ad643802927e4d3e22d11afeab067 (patch)
treece5bf35caf13f91bf423c119dbc09229d60ffd62
downloadaur-cae0b887516ad643802927e4d3e22d11afeab067.tar.gz
5.26.90.r123.gdc122e69-1
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d841e2080e75
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = xcursor-breeze-git
+ pkgdesc = KDE Plasma 5 'Breeze' cursor theme. This package is for usage in non-KDE Plasma desktops.
+ pkgver = 5.26.90.r123.gdc122e69
+ pkgrel = 1
+ url = https://github.com/KDE/breeze
+ arch = any
+ license = GPL
+ depends = libxcursor
+ conflicts = breeze
+ conflicts = xcursor-breeze
+ source = git+https://github.com/KDE/breeze.git
+ b2sums = SKIP
+
+pkgname = xcursor-breeze-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec8c72c8a7d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Akatsuki Rui <akiirui@outlook.com>
+# Contributor: goetzc
+# Contributor: Philip Goto <philip.goto@gmail.com>
+# Contributor: grimi
+
+_pkgname=breeze
+pkgname=xcursor-breeze-git
+pkgver=5.26.90.r123.gdc122e69
+pkgrel=1
+pkgdesc="KDE Plasma 5 'Breeze' cursor theme. This package is for usage in non-KDE Plasma desktops."
+arch=('any')
+depends=('libxcursor')
+url="https://github.com/KDE/breeze"
+license=('GPL')
+conflicts=('breeze' 'xcursor-breeze')
+source=("git+https://github.com/KDE/breeze.git")
+b2sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+
+ git describe --long --tags | sed "s/^v//;s/\([^-]*-g\)/r\1/;s/-/./g"
+}
+
+package() {
+ install -dm755 "$pkgdir"/usr/share/icons/
+ cp -r "$srcdir/$_pkgname"/cursors/Breeze/Breeze/ "$pkgdir"/usr/share/icons/
+ cp -r "$srcdir/$_pkgname"/cursors/Breeze_Light/Breeze_Light/ "$pkgdir"/usr/share/icons/
+}