summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Lima2018-07-21 14:45:00 -0300
committerDaniel Lima2018-07-21 14:45:00 -0300
commitbbc984b443da90e1f65bd0bc50dc29a0e3704201 (patch)
treefd52530914bb18abbbbbe3ee83018f8dfe6f2341
downloadaur-bbc984b443da90e1f65bd0bc50dc29a0e3704201.tar.gz
update revision numbering
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6788486a0a40
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sat Jul 21 17:44:42 UTC 2018
+pkgbase = xcursor-capitaine-git
+ pkgdesc = Capitaine Cursors - an x-cursor theme inspired by macOS and based on KDE Breeze
+ pkgver = 2.1.r2.g3ae9ace
+ pkgrel = 1
+ url = https://krourke.org/projects/art/capitaine-cursors
+ arch = any
+ license = LGPLv3
+ conflicts = xcursor-capitaine
+ conflicts = capitaine-cursors
+ source = git+https://github.com/keeferrourke/capitaine-cursors
+ md5sums = SKIP
+
+pkgname = xcursor-capitaine-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4fee1df5a35
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Daniel Lima <danielm@nanohub.tk>
+
+pkgname=xcursor-capitaine-git
+conflicts=('xcursor-capitaine'
+ 'capitaine-cursors')
+pkgver=2.1.r2.g3ae9ace
+pkgrel=1
+pkgdesc='Capitaine Cursors - an x-cursor theme inspired by macOS and based on KDE Breeze'
+arch=('any')
+url='https://krourke.org/projects/art/capitaine-cursors'
+license=('LGPLv3')
+source=(git+https://github.com/keeferrourke/capitaine-cursors)
+md5sums=('SKIP')
+
+pkgver() {
+ cd $srcdir/capitaine-cursors
+ git describe --tags | sed 's/^r//;s/-/.r/;s/-/./g'
+}
+
+package() {
+ cd $srcdir/capitaine-cursors
+ install -d $pkgdir/usr/share/icons/
+ cp -pr $srcdir/capitaine-cursors/dist/ $pkgdir/usr/share/icons/capitaine-cursors
+}
+