summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2023-04-01 19:53:52 +0200
committerAntonio Rojas2023-04-01 19:53:52 +0200
commit70486748be90be8d73bf07efa1b2f03ca2281186 (patch)
treebed0f676f39e12cf681e62ccccb27f3bf63dd0b3
downloadaur-70486748be90be8d73bf07efa1b2f03ca2281186.tar.gz
import from community
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..146c5dcd6b24
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = xcursor-flatbed
+ pkgdesc = Flatbed XCursor Theme
+ pkgver = 0.5
+ pkgrel = 1
+ url = https://www.limitland.de/flatbedcursors.html
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = xorg-xcursorgen
+ makedepends = librsvg
+ makedepends = bc
+ source = git+https://gitlab.com/limitland/flatbedcursors.git#tag=0.5
+ md5sums = SKIP
+
+pkgname = xcursor-flatbed
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47c7c3eccc10
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Roman Kyrylych <Roman.Kyrylych@gmail.com>
+# Contributor: Lee.MaRS <leemars@gmail.com>
+# Maintainer: Daniel J Griffiths <ghost1227@archlinux.us>
+
+pkgname=xcursor-flatbed
+pkgver=0.5
+pkgrel=1
+pkgdesc="Flatbed XCursor Theme"
+arch=('any')
+url="https://www.limitland.de/flatbedcursors.html"
+license=('GPL3')
+makedepends=('git' 'xorg-xcursorgen' 'librsvg' 'bc')
+source=("git+https://gitlab.com/limitland/flatbedcursors.git#tag=$pkgver")
+md5sums=('SKIP')
+
+package() {
+ cd "$srcdir/flatbedcursors"
+
+ export ICONSDIR="$pkgdir/usr/share/icons/"
+ mkdir -p "$pkgdir/usr/share/icons/"
+ ./install-all
+}