summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikael Blomstrand2018-10-18 22:35:52 +0200
committerMikael Blomstrand2018-10-18 22:35:52 +0200
commitcb6eb499c1bdc165ccb3442b0ecf420758efd07b (patch)
treee34cbf9e871853e969e0f2ca99dd0230e77479e7
parent941bfd42b71e4f47b64fbbab95b0d394c775d57c (diff)
downloadaur-cb6eb499c1bdc165ccb3442b0ecf420758efd07b.tar.gz
source, pkgver, optdepends.
Changed source to gitlab. Added pkgver() function. Removed optdepends.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a0a74e490f0..3270f57dbedf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,14 @@
-# Generated by mksrcinfo v8
-# Thu May 5 08:23:07 UTC 2016
pkgbase = xcursor-maia
pkgdesc = Cursor theme - part of the Manjaro Maia set
pkgver = 20160417
pkgrel = 1
- url = https://github.com/manjaro/maia-cursor
+ url = https://gitlab.manjaro.org/artwork/cursors/maia-cursor
arch = any
license = GPL3
makedepends = binutils
makedepends = git
depends = libxcursor
- optdepends = menda-icon-theme: Official icon theme
- optdepends = menda-gtk-theme: Official theming
- source = git+https://github.com/manjaro/maia-cursor.git
+ source = git+https://gitlab.manjaro.org/artwork/cursors/maia-cursor.git
source = thumbnail.png
md5sums = SKIP
md5sums = 0a7352c3d38d4670fb38393ea4ac555c
diff --git a/PKGBUILD b/PKGBUILD
index daf7df958346..5ecab931ec5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
-# Maintainer: Philip Müller <philm@manjaro.org>
-# Contributor: Lane Wiscombe <assassin.anex@gmail.com>
+# Maintainer: Mikael Blomstrand <mbloms ÅT kth DÖT se>
# Submiter to AUR: Pablo Lezaeta <prflr 88 (arro'a) gmail puntocom>
+# Contributor: Philip Müller <philm@manjaro.org>
+# Contributor: Lane Wiscombe <assassin.anex@gmail.com>
pkgname=xcursor-maia
_gitname=maia-cursor
@@ -8,17 +9,20 @@ pkgver=20160417
pkgrel=1
pkgdesc="Cursor theme - part of the Manjaro Maia set"
arch=('any')
-url="https://github.com/manjaro/$_gitname"
+url="https://gitlab.manjaro.org/artwork/cursors/maia-cursor"
license=('GPL3')
depends=('libxcursor')
-optdepends=("menda-icon-theme: Official icon theme"
- "menda-gtk-theme: Official theming")
makedepends=('binutils' 'git')
source=("git+$url.git"
'thumbnail.png')
md5sums=('SKIP'
'0a7352c3d38d4670fb38393ea4ac555c')
+pkgver() {
+ cd $_gitname
+ git log -1 --format=%cd --date=format:%Y%m%d
+}
+
package() {
mkdir -p $pkgdir/usr/share/icons
cp -a $srcdir/maia-cursor/Maia-Cursor/ $pkgdir/usr/share/icons/