summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorreplabrobin2020-12-11 15:44:00 +0000
committerreplabrobin2020-12-11 15:44:00 +0000
commite86fac115e1c3258de5cda6416c0fd0ec8cd0f4f (patch)
tree6e8383892c9ccee3b0f52a2cf66ea69b8f0508b9
parent0d4b7445a0dbbb4000833fefa52288320b7115a8 (diff)
downloadaur-e86fac115e1c3258de5cda6416c0fd0ec8cd0f4f.tar.gz
use official source https://github.com/ducakar/xcursor-neutralxx
-rw-r--r--.SRCINFO7
-rw-r--r--Neutral++-1.0.3.tar.xzbin43751 -> 0 bytes
-rw-r--r--PKGBUILD20
3 files changed, 18 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb4b634ceed9..2c578351c3c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = xcursor-neutral++
pkgdesc = Icon set based on Neutral and jaguarx themes.
pkgver = 1.0.3
- pkgrel = 3
+ pkgrel = 4
+ url = https://github.com/ducakar/xcursor-neutralxx
arch = any
license = Artistic 2.0
- source = Neutral++-1.0.3.tar.xz
- sha256sums = 23ec4fa3f7b62c023b8726b70d7a822ecd1f3cf90515b302d988f6fe58bce426
+ source = git+https://github.com/ducakar/xcursor-neutralxx.git
+ sha256sums = SKIP
pkgname = xcursor-neutral++
diff --git a/Neutral++-1.0.3.tar.xz b/Neutral++-1.0.3.tar.xz
deleted file mode 100644
index d15e446aefc6..000000000000
--- a/Neutral++-1.0.3.tar.xz
+++ /dev/null
Binary files differ
diff --git a/PKGBUILD b/PKGBUILD
index 43bca3ae1085..72267710aaea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,30 @@
# Maintainer: Alexander De Sousa <archaur.xandy21@spamgourmet.com>
+# Maintainer: Robin Becker <robin@reporrtlab.com>
pkgname=xcursor-neutral++
pkgver=1.0.3
-pkgrel=3
+pkgrel=4
pkgdesc="Icon set based on Neutral and jaguarx themes."
arch=('any')
-#url="https://dl.opendesktop.org/api/files/download/id/1460735294/108142-Neutral++-$pkgver.tar.xz"
+url="https://github.com/ducakar/xcursor-neutralxx"
license=('Artistic 2.0')
-#source=(https://dl.opendesktop.org/api/files/download/id/1460735294/s/5ce93eb392694040136bff1805802bc7/t/1539154277/u//108142-Neutral%20%20-1.0.3.tar.xz)
-source=(Neutral++-1.0.3.tar.xz)
-sha256sums=('23ec4fa3f7b62c023b8726b70d7a822ecd1f3cf90515b302d988f6fe58bce426')
+source=(git+$url.git)
+sha256sums=('SKIP')
build() {
true
}
+prepare(){
+ cd $srcdir
+ [ ! -h Neutral++ ] && ln -s xcursor-neutralxx Neutral++
+ cd Neutral++/source
+ ./make.sh
+ }
+
package(){
cd $srcdir
mkdir -p $pkgdir/usr/share/icons
- cp -r Neutral++ $pkgdir/usr/share/icons
+ cp -r Neutral++/ $pkgdir/usr/share/icons
+ rm -rf $pkgdir/usr/share/icons/Neutral++/{source,.git}
}