summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMauro Santos2017-05-01 20:59:30 +0100
committerMauro Santos2017-05-01 20:59:30 +0100
commitd384a89d4f41770c10894767b5f36c271c922a45 (patch)
tree50671157c98e4fc7411476e2d37457a54d1f1e13
downloadaur-d384a89d4f41770c10894767b5f36c271c922a45.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD36
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8fa3d233642d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+# Generated by mksrcinfo v8
+# Mon May 1 19:59:30 UTC 2017
+pkgbase = xcursor-polar
+ pkgdesc = Polar XCursor Theme
+ pkgver = 1.4
+ pkgrel = 1
+ url = https://store.kde.org/content/show.php?content=27913
+ arch = any
+ license = GPL
+ source = https://dl.opendesktop.org/api/files/download/id/1460735356/27913-PolarCursorThemes.tar.bz2
+ md5sums = 886068e0feadd2a07c8b206b211548ec
+
+pkgname = xcursor-polar
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1950a04a009e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+27913-PolarCursorThemes.tar.bz2
+xcursor-polar-*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..da9275ac64b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Contributor: Dario Andres Rodriguez
+# Contributor: Roman Kyrylych <Roman.Kyrylych@gmail.com>
+# Contributer: Daniel J Griffiths <ghost1227@archlinux.us>
+# Maintainer: Mauro Santos <registo.mailling@gmail.com>
+
+pkgname=xcursor-polar
+pkgver=1.4
+pkgrel=1
+pkgdesc="Polar XCursor Theme"
+arch=('any')
+url="https://store.kde.org/content/show.php?content=27913"
+#url="https://www.gnome-look.org/p/999968/"
+license=('GPL')
+source=(https://dl.opendesktop.org/api/files/download/id/1460735356/27913-PolarCursorThemes.tar.bz2)
+md5sums=('886068e0feadd2a07c8b206b211548ec')
+
+package() {
+ mkdir -p "${pkgdir}"/usr/share/icons/{Polar,Polar-Green,Polar-Blue}
+
+ cp -R "${srcdir}"/PolarCursorTheme/cursors "${pkgdir}"/usr/share/icons/Polar
+ sed s/PolarCursorTheme/Polar/ -i "${srcdir}"/PolarCursorTheme/index.theme
+ install -Dm644 "${srcdir}"/PolarCursorTheme/index.theme \
+ "${pkgdir}"/usr/share/icons/Polar/index.theme
+
+ cp -R "${srcdir}"/PolarCursorTheme-Green/cursors \
+ "${pkgdir}"/usr/share/icons/Polar-Green
+ sed s/PolarCursorTheme/Polar/ -i "${srcdir}"/PolarCursorTheme-Green/index.theme
+ install -Dm644 "${srcdir}"/PolarCursorTheme-Green/index.theme \
+ "${pkgdir}"/usr/share/icons/Polar-Green/index.theme
+
+ cp -R "${srcdir}"/PolarCursorTheme-Blue/cursors \
+ "${pkgdir}"/usr/share/icons/Polar-Blue
+ sed s/PolarCursorTheme/Polar/ -i "${srcdir}"/PolarCursorTheme-Blue/index.theme
+ install -Dm644 "${srcdir}"/PolarCursorTheme-Blue/index.theme \
+ "${pkgdir}"/usr/share/icons/Polar-Blue/index.theme
+}