summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormdomlop2019-03-06 08:14:56 +0100
committermdomlop2019-03-06 08:14:56 +0100
commit35aea4985fb23f153a28c18d2067a8f24d9d16e2 (patch)
treeee562faa59532b1f814536163c72e61181b7e544
downloadaur-35aea4985fb23f153a28c18d2067a8f24d9d16e2.tar.gz
First stable release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae5217098c55
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = xcursor-retrosmart
+ pkgdesc = A retrosmart look collection of cursors for X.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/mdomlop/retrosmart-x11-cursors
+ arch = any
+ license = GPL3
+ optdepends = retrosmart-kvantum-theme: The corresponding theme for Kvantum
+ optdepends = retrosmart-qtcurve-theme: The corresponding theme for QtCurve
+ optdepends = retrosmart-openbox-themes: The corresponding Openbox themes
+ optdepends = retrosmart-wallpapers: The corresponding backgrounds project
+ optdepends = retrosmart-xfwm4-themes: The corresponding XFwm4 themes
+ source = https://github.com/mdomlop/retrosmart-x11-cursors/archive/1.0.tar.gz
+ md5sums = 04c42a604e316abd7067237647e537fa
+
+pkgname = xcursor-retrosmart
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d020e3941c4f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Manuel Domínguez López
+# <mdomlop at gmail dot com>
+# @mdomlop at telegram
+
+_pkgver_year=2019
+_pkgver_month=03
+_pkgver_day=05
+
+pkgname=xcursor-retrosmart
+name=retrosmart-x11-cursors
+pkgver=1.0
+pkgrel=1
+pkgdesc="A retrosmart look collection of cursors for X."
+url="https://github.com/mdomlop/$name"
+source=("https://github.com/mdomlop/$name/archive/$pkgver.tar.gz")
+md5sums=('04c42a604e316abd7067237647e537fa')
+license=('GPL3')
+builddepends=('imagemagick' 'xorg-xcursorgen')
+optdepends=('retrosmart-kvantum-theme: The corresponding theme for Kvantum'
+ 'retrosmart-qtcurve-theme: The corresponding theme for QtCurve'
+ 'retrosmart-openbox-themes: The corresponding Openbox themes'
+ 'retrosmart-wallpapers: The corresponding backgrounds project'
+ 'retrosmart-xfwm4-themes: The corresponding XFwm4 themes')
+arch=('any')
+group=('retrosmart')
+#changelog=Changelog
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make
+ }
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make install DESTDIR=$pkgdir
+}