summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2022-11-09 00:04:48 +0200
committerAdrian Perez de Castro2022-11-09 00:04:48 +0200
commit0e9e8e63a3bd95687d2cf8a16baa0e0ab2c0947c (patch)
tree089579d986f4f90689a4afaca0c03b94bc489980
parent14467267820be4b5119eacfd01b1bf7db0eec75b (diff)
downloadaur-0e9e8e63a3bd95687d2cf8a16baa0e0ab2c0947c.tar.gz
Bump to version 20221103.2
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD43
2 files changed, 54 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d92211363f34..a462ba4d5c45 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,39 @@
pkgbase = xcursor-simp1e
pkgdesc = An aesthetic cursor theme
- pkgver = 6.0
+ pkgver = 20221103.2
pkgrel = 1
- url = https://gitlab.com/zoli111/simp1e/
+ url = https://gitlab.com/cursors/simp1e
arch = any
license = GPL3
makedepends = git
makedepends = librsvg
makedepends = python-pillow
makedepends = xorg-xcursorgen
- source = xcursor-simp1e::git+https://gitlab.com/zoli111/simp1e/#commit=607b83e3b77a18e5c0dcbceee6c1417b89bfd94f
- source = builder_script::git+https://github.com/mxre/cursor
+ source = xcursor-simp1e::git+https://gitlab.com/cursors/simp1e.git/#tag=20221103.2
+ source = cursor-generator::git+https://gitlab.com/cursors/cursor-generator.git/
sha512sums = SKIP
sha512sums = SKIP
-pkgname = xcursor-simp1e
-
pkgname = xcursor-simp1e-breeze
pkgname = xcursor-simp1e-breeze-snow
+pkgname = xcursor-simp1e
+
pkgname = xcursor-simp1e-dark
-pkgname = xcursor-simp1e-catpuccin
+pkgname = xcursor-simp1e-adw
+
+pkgname = xcursor-simp1e-adw-dark
+
+pkgname = xcursor-simp1e-catpuccin-frappe
+ replaces = xcursor-simp1e-catpuccin
+
+pkgname = xcursor-simp1e-catpuccin-latte
+
+pkgname = xcursor-simp1e-catpuccin-macchiato
+
+pkgname = xcursor-simp1e-catpuccin-mocha
pkgname = xcursor-simp1e-solarized-dark
@@ -38,3 +49,7 @@ pkgname = xcursor-simp1e-nord-dark
pkgname = xcursor-simp1e-nord-light
pkgname = xcursor-simp1e-tokyo-night
+
+pkgname = xcursor-simp1e-tokyo-night-light
+
+pkgname = xcursor-simp1e-tokyo-night-storm
diff --git a/PKGBUILD b/PKGBUILD
index 5c9aa59d1f0c..b360476de7bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,27 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
pkgbase=xcursor-simp1e
-pkgname=(xcursor-simp1e{,-breeze{,-snow},-dark,-catpuccin,-{solarized,gruvbox,nord}-{dark,light},-tokyo-night})
+pkgname=(xcursor-simp1e{-breeze{,-snow},{,-adw}{,-dark},-catpuccin-{frappe,latte,macchiato,mocha},-{solarized,gruvbox,nord}-{dark,light},-tokyo-night{,-light,-storm}})
pkgdesc='An aesthetic cursor theme'
-pkgver=6.0
+pkgver=20221103.2
pkgrel=1
-url=https://gitlab.com/zoli111/simp1e/
-_commit=607b83e3b77a18e5c0dcbceee6c1417b89bfd94f
+url=https://gitlab.com/cursors/simp1e
arch=(any)
makedepends=(git librsvg python-pillow xorg-xcursorgen)
depends=()
license=(GPL3)
-source=("${pkgname}::git+${url}#commit=${_commit}"
- "builder_script::git+https://github.com/mxre/cursor")
+source=("${pkgbase}::git+${url}.git/#tag=${pkgver}"
+ "cursor-generator::git+https://gitlab.com/cursors/cursor-generator.git/")
sha512sums=(SKIP SKIP)
prepare () {
- cd "${pkgname}"
+ cd "${pkgbase}"
git submodule init
- git config submodule.builder_script.url "${srcdir}/builder_script"
- git submodule update
+ git config submodule.cursor-generator.url "${srcdir}/cursor-generator"
+ git -c protocol.file.allow=always submodule update
}
build () {
- cd "${pkgname}"
+ cd "${pkgbase}"
./build.sh
}
@@ -37,6 +36,12 @@ package_xcursor-simp1e () {
package_xcursor-simp1e-dark () {
_package Simp1e-Dark
}
+package_xcursor-simp1e-adw () {
+ _package Simp1e-Adw
+}
+package_xcursor-simp1e-adw-dark () {
+ _package Simp1e-Adw-Dark
+}
package_xcursor-simp1e-breeze () {
_package Simp1e-Breeze
}
@@ -65,6 +70,22 @@ package_xcursor-simp1e-nord-dark () {
package_xcursor-simp1e-tokyo-night () {
_package Simp1e-Tokyo-Night
}
-package_xcursor-simp1e-catpuccin () {
+package_xcursor-simp1e-tokyo-night-light () {
+ _package Simp1e-Tokyo-Night-Light
+}
+package_xcursor-simp1e-tokyo-night-storm () {
+ _package Simp1e-Tokyo-Night-Light
+}
+package_xcursor-simp1e-catpuccin-frappe () {
+ replaces=(xcursor-simp1e-catpuccin)
_package Simp1e-Catppuccin-Frappe
}
+package_xcursor-simp1e-catpuccin-latte () {
+ _package Simp1e-Catppuccin-Latte
+}
+package_xcursor-simp1e-catpuccin-macchiato () {
+ _package Simp1e-Catppuccin-Macchiato
+}
+package_xcursor-simp1e-catpuccin-mocha () {
+ _package Simp1e-Catppuccin-Mocha
+}