summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDevin J. Pohly2015-07-02 13:47:33 -0400
committerDevin J. Pohly2015-07-02 13:47:33 -0400
commite975f9d354ddb3783704fa9a599602c1b8d6c4df (patch)
treec054bfd70ed629abd9d6f2eab9cd649c27e11e8c
downloadaur-e975f9d354ddb3783704fa9a599602c1b8d6c4df.tar.gz
Import from AUR3
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD29
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..add00d4c1f93
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = xcursor-transparent-theme
+ pkgdesc = Completely transparent theme for hiding the X11 cursor
+ pkgver = 0.1.1
+ pkgrel = 2
+ url = http://downloads.yoctoproject.org/releases/matchbox/utils/xcursor-transparent-readme.txt
+ arch = any
+ license = GPL
+ source = http://downloads.yoctoproject.org/releases/matchbox/utils/xcursor-transparent-theme-0.1.1.tar.gz
+ sha1sums = eab5e65ccab0c6fd4a8e974926127e1e151a6c83
+
+pkgname = xcursor-transparent-theme
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4dc50f94f668
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Devin J. Pohly <djpohly+arch@gmail.com>
+pkgname=xcursor-transparent-theme
+pkgver=0.1.1
+pkgrel=2
+pkgdesc="Completely transparent theme for hiding the X11 cursor"
+arch=(any)
+url="http://downloads.yoctoproject.org/releases/matchbox/utils/xcursor-transparent-readme.txt"
+license=('GPL')
+source=("http://downloads.yoctoproject.org/releases/matchbox/utils/xcursor-transparent-theme-0.1.1.tar.gz")
+sha1sums=('eab5e65ccab0c6fd4a8e974926127e1e151a6c83')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i 's|ln -s \$(DESTDIR)\$(CURSOR_DIR)/transp|ln -s transp|' cursors/Makefile.in
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: