summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Houdebert2015-07-08 13:19:32 +0200
committerKevin Houdebert2015-07-08 13:19:32 +0200
commit7b3ba168c455482b70b9e9af95a6077272780452 (patch)
treeedd3cb770ed6dc0bbaa0ddcb56906d0550ad95f9
downloadaur-7b3ba168c455482b70b9e9af95a6077272780452.tar.gz
Import from AUR3
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad22176135c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = xcwd-git
+ pkgdesc = xcwd is a simple tool that prints the current working directory of the currently focused window.
+ pkgver = 20130929
+ pkgrel = 1
+ url = http://github.com/schischi-a/xcwd.git
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = libx11
+ source = git://github.com/schischi-a/xcwd
+ md5sums = SKIP
+
+pkgname = xcwd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..04ea1b16ffae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Franck Michea <franck.michea@gmail.com>
+# Submitter: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: _@killown.com
+
+pkgname=xcwd-git
+pkgver=20130929
+pkgrel=1
+pkgdesc="xcwd is a simple tool that prints the current working directory of the currently focused window."
+arch=('i686' 'x86_64')
+license=('BSD')
+depends=('libx11')
+makedepends=('git')
+url="http://github.com/schischi-a/xcwd.git"
+source=('git://github.com/schischi-a/xcwd')
+md5sums=('SKIP')
+_gitname="xcwd"
+
+pkgver() {
+ cd $srcdir/$_gitname
+ echo $(git log -1 --format="%cd" --date=short | sed 's|-||g')
+}
+
+build() {
+ cd $srcdir/$_gitname
+ make prefix=/usr
+}
+
+package() {
+ cd $srcdir/$_gitname
+ install -Dm0755 $_gitname $pkgdir/usr/bin/$_gitname
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$_gitname/LICENSE
+}