summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Wagner2015-06-14 10:17:28 -0400
committerAndreas Wagner2015-06-14 10:17:28 -0400
commit02da1db1af63f8ce30415aed681411390bd82731 (patch)
tree2a59826ae2c5e7e48b390b6528bc0fc29ff066cc
downloadaur-02da1db1af63f8ce30415aed681411390bd82731.tar.gz
Initial import.
-rw-r--r--.SRCINFO17
-rw-r--r--COPYING1
-rw-r--r--PKGBUILD27
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..750e59409255
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = xd
+ pkgdesc = a utility for dumping files in hex, decimal, or octal
+ pkgver = 1
+ pkgrel = 3
+ url = http://www.fourmilab.ch/xd
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = gcc
+ options = zipman
+ source = http://www.fourmilab.ch/xd/xd.zip
+ source = COPYING
+ md5sums = 304184cb2bd79900c4750dcab481033a
+ md5sums = 5cf61120e8516a804a13731920518974
+
+pkgname = xd
+
diff --git a/COPYING b/COPYING
new file mode 100644
index 000000000000..9be6a5b7542c
--- /dev/null
+++ b/COPYING
@@ -0,0 +1 @@
+This software is in the public domain. Permission to use, copy, modify, and distribute this software and its documentation for any purpose and without fee is hereby granted, without any conditions or restrictions. This software is provided "as is" without express or implied warranty.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c265d97d018b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Andreas B. Wagner <AndreasBWagner@pointfree.net>
+# Contributor: Michael Blum <michaeldblum@earthlink.net>
+pkgname=xd
+pkgver=1
+pkgrel=3
+pkgdesc='a utility for dumping files in hex, decimal, or octal'
+arch=('i686' 'x86_64')
+url="http://www.fourmilab.ch/xd"
+license=('custom')
+depends=()
+makedepends=(gcc)
+source=("http://www.fourmilab.ch/$pkgname/$pkgname.zip" 'COPYING')
+options=('zipman')
+md5sums=('304184cb2bd79900c4750dcab481033a'
+ '5cf61120e8516a804a13731920518974')
+
+build() {
+ cd $srcdir/
+ make
+}
+package() {
+ install -Dm755 xd $pkgdir/usr/bin/xd
+ install -Dm644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/COPYING
+ install -Dm644 xd.1 $pkgdir/usr/share/man/man1/xd.1
+}
+
+# vim:set ts=2 sw=2 et: