summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2020-02-11 09:10:13 -0700
committerBrian Bidulock2020-02-11 09:10:13 -0700
commit069b23e1e15fe89bf8cb92df7ed1d8d9ce16761b (patch)
tree83b6b307dfe4219ca534a530b07d90c2e0a80fb6
parentb987cba197a0bc7f9819569361575b869d6179a6 (diff)
downloadaur-069b23e1e15fe89bf8cb92df7ed1d8d9ce16761b.tar.gz
uppkg
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0ccb9b82a1b..0bbc9659564f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xde-ctools
pkgdesc = X Desktop Environment C-language tools
- pkgver = 1.11
+ pkgver = 1.12
pkgrel = 1
url = https://github.com/bbidulock/xde-ctools
arch = i686
@@ -15,8 +15,8 @@ pkgbase = xde-ctools
depends = libcanberra
depends = libnotify
optdepends = xdg-launch: launch with recent update and launch notification
- source = https://github.com/bbidulock/xde-ctools/releases/download/1.11/xde-ctools-1.11.tar.lz
- sha256sums = 43130ac08a69083fe74e9efd8b6d40b94463296af1d637c94fb18da697c1f8da
+ source = https://github.com/bbidulock/xde-ctools/releases/download/1.12/xde-ctools-1.12.tar.lz
+ sha256sums = 750583c76cf50bdf96f3283914f37fa33b508f4f1692680ec39a0e06685fe02b
pkgname = xde-ctools
diff --git a/PKGBUILD b/PKGBUILD
index 4d229e1e7f8a..8e35a203509d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Brian Bidulock <bidulock@openss7.org>
pkgname=xde-ctools
-pkgver=1.11
+pkgver=1.12
pkgrel=1
pkgdesc="X Desktop Environment C-language tools"
groups=('xde')
@@ -12,12 +12,15 @@ depends=('libxss' 'libsm' 'libwnck+' 'libcanberra' 'libnotify')
makedepends=('dbus-glib' 'libunique')
optdepends=('xdg-launch: launch with recent update and launch notification')
source=("https://github.com/bbidulock/xde-ctools/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.lz")
-sha256sums=('43130ac08a69083fe74e9efd8b6d40b94463296af1d637c94fb18da697c1f8da')
+sha256sums=('750583c76cf50bdf96f3283914f37fa33b508f4f1692680ec39a0e06685fe02b')
build() {
cd $pkgname-$pkgver
- ./configure --sysconfdir=/etc
- make
+ # gtk2 is using deprecated glib2 declarations
+ ./configure --sysconfdir=/etc CFLAGS="-Wno-deprecated-declarations $CFLAGS"
+ # Fight unused direct deps
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/ if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/ func_append compile_command " -Wl,-O1,--as-needed"\n func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
+ make CFLAGS="-Wno-deprecated-declarations $CFLAGS"
}
package() {