summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2022-01-29 02:23:20 -0700
committerBrian Bidulock2022-01-29 02:23:20 -0700
commitf81084a4077e9e5231dde7d6cee87dd0afb9ac80 (patch)
tree100d488903b5b5cc6590e668ab2ef7cc5da19574
parent807510f7b1f8d96775caa905fb67fc4c31389cad (diff)
downloadaur-f81084a4077e9e5231dde7d6cee87dd0afb9ac80.tar.gz
version 1.15
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e81b7b3b47a..6da3a44ff3ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xde-ctools
pkgdesc = X Desktop Environment C-language tools
- pkgver = 1.14
+ pkgver = 1.15
pkgrel = 1
url = https://github.com/bbidulock/xde-ctools
arch = i686
@@ -9,15 +9,14 @@ pkgbase = xde-ctools
license = GPL
makedepends = dbus-glib
makedepends = libunique
+ makedepends = xorgproto
+ makedepends = libnotify
+ makedepends = gdk-pixbuf-xlib
depends = libxss
- depends = libsm
depends = libwnck+
depends = libcanberra
- depends = libnotify
- depends = gdk-pixbuf-xlib
optdepends = xdg-launch: launch with recent update and launch notification
- source = https://github.com/bbidulock/xde-ctools/releases/download/1.14/xde-ctools-1.14.tar.lz
- sha256sums = 80d4378a7d5724127323d7795b74cde5634c22cacbc04807bda4c2f28f308117
+ source = https://github.com/bbidulock/xde-ctools/releases/download/1.15/xde-ctools-1.15.tar.lz
+ sha256sums = 103484ed27ab8924f4d525bc8b453e6976c3fec324863aff5f413fcb730f6291
pkgname = xde-ctools
-
diff --git a/PKGBUILD b/PKGBUILD
index 15e289797aef..1df4b952e0e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,28 @@
# Maintainer: Brian Bidulock <bidulock@openss7.org>
pkgname=xde-ctools
-pkgver=1.14
+pkgver=1.15
pkgrel=1
pkgdesc="X Desktop Environment C-language tools"
groups=('xde')
arch=('i686' 'x86_64')
-url="https://github.com/bbidulock/xde-ctools"
+url="https://github.com/bbidulock/$pkgname"
license=('GPL')
-depends=('libxss' 'libsm' 'libwnck+' 'libcanberra' 'libnotify' 'gdk-pixbuf-xlib')
-makedepends=('dbus-glib' 'libunique')
+depends=('libxss' 'libwnck+' 'libcanberra')
+makedepends=('dbus-glib' 'libunique' 'xorgproto' 'libnotify' 'gdk-pixbuf-xlib')
optdepends=('xdg-launch: launch with recent update and launch notification')
-source=("https://github.com/bbidulock/xde-ctools/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.lz")
-sha256sums=('80d4378a7d5724127323d7795b74cde5634c22cacbc04807bda4c2f28f308117')
+source=("https://github.com/bbidulock/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.lz")
+sha256sums=('103484ed27ab8924f4d525bc8b453e6976c3fec324863aff5f413fcb730f6291')
build() {
cd $pkgname-$pkgver
# gtk2 is using deprecated glib2 declarations
./configure --sysconfdir=/etc CFLAGS="-Wno-deprecated-declarations $CFLAGS"
# Fight unused direct deps
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/ if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/ func_append compile_command " -Wl,-O1,--as-needed"\n func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
+ sed -i -e "s| -shared | $LDFLAGS\0 |g" -e "s| if test \"\$export_dynamic\" = yes && test -n \"\$export_dynamic_flag_spec\"; then| func_append compile_command \" $LDFLAGS\"\n func_append finalize_command \" $LDFLAGS\"\n\0|" libtool
make CFLAGS="-Wno-deprecated-declarations $CFLAGS"
}
package() {
- cd $pkgname-$pkgver
- make DESTDIR="$pkgdir" install
+ make -C $pkgname-$pkgver DESTDIR="$pkgdir" install
}