summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2019-09-05 15:06:18 -0600
committerBrian Bidulock2019-09-05 15:06:18 -0600
commit8bb569bb4143247dac8630833687fb6bb3662d6d (patch)
tree747d5670096a5bd54ed33520c7339251ce545f82
parent78733a6f0f30f5c7b43699e159f12ca2b8af0c46 (diff)
downloadaur-8bb569bb4143247dac8630833687fb6bb3662d6d.tar.gz
correct group
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d9e8448a42c..df3c15729786 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = xde-menu-git
pkgdesc = XDG compliant menu generator
pkgver = 0.11.r0.g7fce7e4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/bbidulock/xde-menu
arch = i686
arch = x86_64
- groups = xde
+ groups = xde-git
license = GPL
makedepends = git
depends = libwnck+-git
@@ -13,7 +13,7 @@ pkgbase = xde-menu-git
depends = gnome-menus
optdepends = xdg-launch-git: for LW WM launch notification
optdepends = xde-theme: for LW WM style and theme change support
- provides = xde-menu
+ provides = xde-menu=0.11.r0.g7fce7e4
conflicts = xde-menu
source = xde-menu-git::git+https://github.com/bbidulock/xde-menu.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 6f55de40c115..b92f85e6c606 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
# Maintainer: Brian Bidulock <bidulock@openss7.org>
pkgname=xde-menu-git
+_pkgname=xde-menu
pkgver=0.11.r0.g7fce7e4
-pkgrel=1
+pkgrel=2
pkgdesc="XDG compliant menu generator"
arch=('i686' 'x86_64')
url="https://github.com/bbidulock/xde-menu"
-groups=('xde')
+groups=('xde-git')
license=('GPL')
-provides=('xde-menu')
-conflicts=('xde-menu')
+provides=($_pkgname=$pkgver)
+conflicts=($_pkgname)
depends=('libwnck+-git' 'libsm' 'gnome-menus')
+makedepends=('git')
optdepends=('xdg-launch-git: for LW WM launch notification'
'xde-theme: for LW WM style and theme change support')
-makedepends=('git')
-source=("$pkgname::git+https://github.com/bbidulock/xde-menu.git")
+source=("$pkgname::git+https://github.com/bbidulock/$_pkgname.git")
md5sums=('SKIP')
pkgver() {
@@ -37,3 +38,5 @@ package() {
cd $pkgname
make DESTDIR="$pkgdir" install
}
+
+# vim: et sw=2: