summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 23:20:03 -0600
committerBrian Bidulock2015-06-10 23:20:03 -0600
commit441d960469c9379b72a0d106339f22593f71e61c (patch)
tree3a476ef8422d7887941917f3dbff0035d03a41d8
downloadaur-441d960469c9379b72a0d106339f22593f71e61c.tar.gz
initial version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD36
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d89302e2737b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = xde-styles
+ pkgdesc = Four consistent styles across light-weight WMs for XDE
+ pkgver = 1.1.79
+ pkgrel = 1
+ url = http://github.com/bbidulock/xde-styles
+ arch = any
+ groups = xde
+ license = CCPL:by-sa
+ makedepends = git
+ depends = m4
+ source = xde-styles::git://github.com/bbidulock/xde-styles.git
+ md5sums = SKIP
+
+pkgname = xde-styles
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f45990f55063
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+pkgname=xde-styles
+pkgver=1.1.79
+pkgrel=1
+pkgdesc="Four consistent styles across light-weight WMs for XDE"
+groups=('xde')
+arch=('any')
+license=('CCPL:by-sa')
+url="http://github.com/bbidulock/xde-styles"
+depends=('m4')
+makedepends=('git')
+source=("$pkgname::git://github.com/bbidulock/$pkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --always | sed 's|-|.|g;s|[.]g[a-f0-9]*$||'
+}
+
+prepare() {
+ cd $pkgname
+ ./autogen.sh
+}
+
+build() {
+ cd $pkgname
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make V=0
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir" install
+}
+
+# vim: et sw=2: