summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2022-04-11 20:23:18 +0200
committerMarcell Meszaros2022-04-11 20:23:52 +0200
commitd8db6d821be9d06d85ba84934c96a5bafeb15f7e (patch)
tree76663e5829aa2a3a5057f310e3f40f7fe0b0c111
parent0a072405d88812b20c233c3f30ff4fba6cb934e9 (diff)
downloadaur-d8db6d821be9d06d85ba84934c96a5bafeb15f7e.tar.gz
fix dependencies again
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b97d05550693..c49ef0f0c3ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xdg-desktop-portal-git
pkgdesc = Desktop integration portals for sandboxed apps
pkgver = 1.14.1.r15.gdfd9539
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://github.com/flatpak/xdg-desktop-portal
arch = x86_64
@@ -18,6 +18,7 @@ pkgbase = xdg-desktop-portal-git
depends = gdk-pixbuf2
depends = geoclue
depends = json-glib
+ depends = systemd
provides = xdg-desktop-portal
conflicts = xdg-desktop-portal
source = git+https://github.com/flatpak/xdg-desktop-portal
@@ -30,4 +31,6 @@ pkgname = xdg-desktop-portal-git
depends = gdk-pixbuf2
depends = geoclue
depends = json-glib
+ depends = systemd
depends = xdg-desktop-portal-impl
+ depends = rtkit
diff --git a/PKGBUILD b/PKGBUILD
index 25100bd5521a..9a47fb859e63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgname=xdg-desktop-portal-git
_pkgname=xdg-desktop-portal
pkgver=1.14.1.r15.gdfd9539
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc="Desktop integration portals for sandboxed apps"
url="https://github.com/flatpak/xdg-desktop-portal"
arch=(x86_64)
license=(LGPL2.1)
-depends=('glib2' 'pipewire' 'fuse3' 'gdk-pixbuf2' 'geoclue' 'json-glib')
+depends=('glib2' 'pipewire' 'fuse3' 'gdk-pixbuf2' 'geoclue' 'json-glib' 'systemd')
makedepends=('python' 'xmlto' 'docbook-xsl' 'git' 'flatpak' 'libportal')
# checkdepends=('epiphany' 'gedit' 'gvfs') # disable if not used in check()
provides=($_pkgname)
@@ -42,7 +42,7 @@ build() {
}
package() {
- depends+=(xdg-desktop-portal-impl)
+ depends+=('xdg-desktop-portal-impl' 'rtkit')
cd $_pkgname
make DESTDIR="$pkgdir" install
}