summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVaxry2024-01-26 23:31:48 +0000
committerVaxry2024-01-26 23:31:48 +0000
commit00afd9701bd6e29b109d0343a1ca0f763d20bdc1 (patch)
tree693c3aa7f75401bed71e7e49bdab33af1bd6ee0f
parent7e16719f9222f03595c4c3e247b667ef2102022b (diff)
downloadaur-00afd9701bd6e29b109d0343a1ca0f763d20bdc1.tar.gz
make it compile xd
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf77102627c9..65b85d794cc0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xdg-desktop-portal-hyprland-git
pkgdesc = xdg-desktop-portal backend for hyprland
- pkgver = r349.1c80212
+ pkgver = r359.5a59264
pkgrel = 1
epoch = 1
url = https://github.com/hyprwm/xdg-desktop-portal-hyprland
diff --git a/PKGBUILD b/PKGBUILD
index 83cec628f432..5320d2fa6071 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
_pkgname="xdg-desktop-portal-hyprland"
pkgname="${_pkgname}-git"
-pkgver=r349.1c80212
+pkgver=r359.5a59264
pkgrel=1
epoch=1
pkgdesc="xdg-desktop-portal backend for hyprland"
url="https://github.com/hyprwm/xdg-desktop-portal-hyprland"
arch=(x86_64)
-license=(custom:MIT)
+license=(BSD)
provides=("${pkgname%-git}" "xdg-desktop-portal-impl" "xdg-desktop-portal-wlr")
conflicts=("${pkgname%-git}" "xdg-desktop-portal-wlr")
depends=(pipewire libinih qt6-base qt6-wayland sdbus-cpp hyprlang)
@@ -33,11 +33,15 @@ pkgver() {
)
}
-build() {
+prepare() {
cd "${srcdir}/${_pkgname}"
git submodule update --init
- cmake --no-warn-unused-cli -DCMAKE_INSTALL_LIBEXECDIR:STRING=/usr/lib -DCMAKE_BUILD_TYPE:STRING=Release -DCMAKE_INSTALL_PREFIX:PATH="${pkgdir}/usr" -S . -B ./build
- cmake --build ./build --config Release --target all -j`nproc 2>/dev/null || getconf NPROCESSORS_CONF`
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ cmake --no-warn-unused-cli -DCMAKE_INSTALL_LIBEXECDIR:STRING=${pkgdir}/usr/lib -DCMAKE_BUILD_TYPE:STRING=Release -DCMAKE_INSTALL_PREFIX:PATH="${pkgdir}/usr" -S . -B ./build
+ cmake --build ./build --config Release --target all
}
package() {