summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralba4k2024-02-24 09:22:26 +0100
committeralba4k2024-02-24 09:22:26 +0100
commit3166eb385c727a456bb4bf0a63bc010bd1684462 (patch)
treed338fb8852c40b696dc1c13ebaac194407077eec
parent00afd9701bd6e29b109d0343a1ca0f763d20bdc1 (diff)
downloadaur-3166eb385c727a456bb4bf0a63bc010bd1684462.tar.gz
fixed pkgbuild
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD31
2 files changed, 21 insertions, 13 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..47f7fbfd9c7b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+xdg-desktop-portal-hyprland*
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
index 5320d2fa6071..9a2ea678090c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,34 +3,30 @@
_pkgname="xdg-desktop-portal-hyprland"
pkgname="${_pkgname}-git"
-pkgver=r359.5a59264
+pkgver=1.3.1.r12.g1b713911
pkgrel=1
-epoch=1
pkgdesc="xdg-desktop-portal backend for hyprland"
url="https://github.com/hyprwm/xdg-desktop-portal-hyprland"
arch=(x86_64)
license=(BSD)
provides=("${pkgname%-git}" "xdg-desktop-portal-impl" "xdg-desktop-portal-wlr")
conflicts=("${pkgname%-git}" "xdg-desktop-portal-wlr")
-depends=(pipewire libinih qt6-base qt6-wayland sdbus-cpp hyprlang)
-makedepends=(git meson wayland-protocols wayland scdoc cmake)
+depends=("libpipewire" "libinih" "qt6-base" "qt6-wayland" "wayland" "sdbus-cpp" "libdrm" "xdg-desktop-portal" "mesa" "hyprlang>=0.2.0")
+makedepends=("git" "wayland-protocols" "scdoc" "cmake")
optdepends=(
"grim: required for the screenshot portal to function"
"slurp: support for interactive mode for the screenshot portal; one of the built-in chooser options for the screencast portal"
- "bemenu: one of the built-in chooser options for the screencast portal"
- "wofi: one of the built-in chooser options for the screencast portal"
"hyprland: the Hyprland compositor"
)
source=("${_pkgname}::git+https://github.com/hyprwm/xdg-desktop-portal-hyprland.git")
sha256sums=('SKIP')
-options=(!makeflags !buildflags !strip)
+
+backup=("etc/xdg/xdg-desktop-portal/hyprland-portals.conf")
pkgver() {
- cd "$_pkgname"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ cd "${_pkgname}"
+ git describe --long --tags --abbrev=8 --exclude='*[a-zA-Z][a-zA-Z]*' \
+ | sed -E 's/^[^0-9]*//;s/([^-]*-g)/r\1/;s/-/./g'
}
prepare() {
@@ -40,13 +36,22 @@ prepare() {
build() {
cd "${srcdir}/${_pkgname}"
+
cmake --no-warn-unused-cli -DCMAKE_INSTALL_LIBEXECDIR:STRING=${pkgdir}/usr/lib -DCMAKE_BUILD_TYPE:STRING=Release -DCMAKE_INSTALL_PREFIX:PATH="${pkgdir}/usr" -S . -B ./build
cmake --build ./build --config Release --target all
}
package() {
- depends=(xdg-desktop-portal)
cd "${srcdir}/${_pkgname}"
cmake --install build
+
+ # Remove ${pkgdir} from Exec paths
+ sed -i -e "s|${pkgdir}||g" "${pkgdir}/usr/share/dbus-1/services/org.freedesktop.impl.portal.desktop.hyprland.service"
+ sed -i -e "s|${pkgdir}||g" "${pkgdir}/usr/lib/systemd/user/xdg-desktop-portal-hyprland.service"
+
+ mkdir -p "${pkgdir}/etc/xdg/xdg-desktop-portal"
+ # https://github.com/hyprwm/xdg-desktop-portal-hyprland/issues/171#issuecomment-1898969439
+ echo -e "[preferred]\ndefault=gtk;hyprland" > "$pkgdir/etc/xdg/xdg-desktop-portal/hyprland-portals.conf"
+
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${_pkgname}"
}