summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralba4k2024-02-24 23:38:07 +0100
committeralba4k2024-02-24 23:38:07 +0100
commit538df915ad78ec65dc91e668d90e603d70a1f2f0 (patch)
tree532d85f1c23c312754fddf542fec2075c98015e5
parent25927dacab92864741c0fe3931aad8a774309e28 (diff)
downloadaur-538df915ad78ec65dc91e668d90e603d70a1f2f0.tar.gz
removed weird sed hacks in package()
-rw-r--r--PKGBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9a2ea678090c..9d9d51370727 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,7 +18,7 @@ optdepends=(
"slurp: support for interactive mode for the screenshot portal; one of the built-in chooser options for the screencast portal"
"hyprland: the Hyprland compositor"
)
-source=("${_pkgname}::git+https://github.com/hyprwm/xdg-desktop-portal-hyprland.git")
+source=("${_pkgname}::git+$url.git")
sha256sums=('SKIP')
backup=("etc/xdg/xdg-desktop-portal/hyprland-portals.conf")
@@ -37,20 +37,17 @@ prepare() {
build() {
cd "${srcdir}/${_pkgname}"
- cmake --no-warn-unused-cli -DCMAKE_INSTALL_LIBEXECDIR:STRING=${pkgdir}/usr/lib -DCMAKE_BUILD_TYPE:STRING=Release -DCMAKE_INSTALL_PREFIX:PATH="${pkgdir}/usr" -S . -B ./build
- cmake --build ./build --config Release --target all
+ cmake -DCMAKE_INSTALL_LIBEXECDIR=/usr/lib -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -S . -B build -Wno-dev
+ cmake --build build --config Release --target all
}
package() {
cd "${srcdir}/${_pkgname}"
- cmake --install build
- # Remove ${pkgdir} from Exec paths
- sed -i -e "s|${pkgdir}||g" "${pkgdir}/usr/share/dbus-1/services/org.freedesktop.impl.portal.desktop.hyprland.service"
- sed -i -e "s|${pkgdir}||g" "${pkgdir}/usr/lib/systemd/user/xdg-desktop-portal-hyprland.service"
+ DESTDIR="${pkgdir}" cmake --install build
- mkdir -p "${pkgdir}/etc/xdg/xdg-desktop-portal"
# https://github.com/hyprwm/xdg-desktop-portal-hyprland/issues/171#issuecomment-1898969439
+ install -dm755 "$pkgdir/etc/xdg/xdg-desktop-portal"
echo -e "[preferred]\ndefault=gtk;hyprland" > "$pkgdir/etc/xdg/xdg-desktop-portal/hyprland-portals.conf"
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${_pkgname}"