summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThatOneCalculator2023-10-19 18:03:06 -0700
committerThatOneCalculator2023-10-19 18:03:06 -0700
commit8e9a58f151b4931146d66b02ce032b80a7bb092d (patch)
treeec9d4fe8cbd4a8cf741343ccbd52a99c0350c15d
parentb35f6aab1f11ab2736e50758fd0da3a0a8eb18b8 (diff)
downloadaur-8e9a58f151b4931146d66b02ce032b80a7bb092d.tar.gz
fix flagged issues
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 761ddb32d2bf..a69a87b6d458 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xdg-desktop-portal-hyprland-git
pkgdesc = xdg-desktop-portal backend for hyprland
- pkgver = r261.e1f145d
- pkgrel = 4
+ pkgver = r321.d8daa2a
+ pkgrel = 1
epoch = 1
url = https://github.com/hyprwm/xdg-desktop-portal-hyprland
arch = x86_64
@@ -12,7 +12,7 @@ pkgbase = xdg-desktop-portal-hyprland-git
makedepends = wayland
makedepends = scdoc
makedepends = cmake
- depends = xdg-desktop-portal
+ makedepends = sdbus-cpp
depends = pipewire
depends = libinih
depends = qt6-base
@@ -34,3 +34,4 @@ pkgbase = xdg-desktop-portal-hyprland-git
sha256sums = SKIP
pkgname = xdg-desktop-portal-hyprland-git
+ depends = xdg-desktop-portal
diff --git a/PKGBUILD b/PKGBUILD
index 3e726f39ebd8..fc312601a5f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_pkgname="xdg-desktop-portal-hyprland"
pkgname="${_pkgname}-git"
-pkgver=r261.e1f145d
-pkgrel=4
+pkgver=r321.d8daa2a
+pkgrel=1
epoch=1
pkgdesc="xdg-desktop-portal backend for hyprland"
url="https://github.com/hyprwm/xdg-desktop-portal-hyprland"
@@ -12,8 +12,8 @@ arch=(x86_64)
license=(custom:MIT)
provides=("${pkgname%-git}" "xdg-desktop-portal-impl" "xdg-desktop-portal-wlr")
conflicts=("${pkgname%-git}" "xdg-desktop-portal-wlr")
-depends=(xdg-desktop-portal pipewire libinih qt6-base qt6-wayland)
-makedepends=(git meson wayland-protocols wayland scdoc cmake)
+depends=(pipewire libinih qt6-base qt6-wayland)
+makedepends=(git meson wayland-protocols wayland scdoc cmake sdbus-cpp)
optdepends=(
"grim: required for the screenshot portal to function"
"slurp: support for interactive mode for the screenshot portal; one of the built-in chooser options for the screencast portal"
@@ -42,6 +42,7 @@ build() {
}
package() {
+ depends=(xdg-desktop-portal)
cd "${srcdir}/${_pkgname}"
DESTDIR="${pkgdir}" ninja -C build install
install -Dm755 hyprland-share-picker/build/hyprland-share-picker -t "${pkgdir}/usr/bin"