summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThatOneCalculator2022-12-05 21:51:54 -0800
committerThatOneCalculator2022-12-05 21:51:54 -0800
commite1b69d6d1ca3c372642698e5128d3161659f72b1 (patch)
tree7b9cc191e22d20a02bfbf711b36a9ad73a86f18d
parent8ca1095084499003a78b9b0192133462497a47e1 (diff)
parentc4697e94efe40d4d1e9e214ffc3a39ebc458f8f1 (diff)
downloadaur-e1b69d6d1ca3c372642698e5128d3161659f72b1.tar.gz
Merge branch 'master' of ssh://aur.archlinux.org/xdg-desktop-portal-hyprland-git
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4269714626b7..c1f500f43cd5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,11 +15,11 @@ pkgbase = xdg-desktop-portal-hyprland-git
depends = pipewire
depends = libinih
depends = qt6-base
+ depends = qt6-wayland
optdepends = grim: required for the screenshot portal to function
optdepends = slurp: support for interactive mode for the screenshot portal; one of the built-in chooser options for the screencast portal
optdepends = bemenu: one of the built-in chooser options for the screencast portal
optdepends = wofi: one of the built-in chooser options for the screencast portal
- optdepends = obs-xdg-portal: support for the screencast portal in obs
optdepends = hyprland: the Hyprland compositor
provides = xdg-desktop-portal-hyprland
provides = xdg-desktop-portal-impl
diff --git a/PKGBUILD b/PKGBUILD
index c06bded37a13..44f76b26d26a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,21 @@
_pkgname="xdg-desktop-portal-hyprland"
pkgname="${_pkgname}-git"
-pkgver=r224.3d3c5a4
-pkgrel=2
+pkgver=r231.bd91bd0
+pkgrel=1
pkgdesc="xdg-desktop-portal backend for hyprland"
url="https://github.com/hyprwm/xdg-desktop-portal-hyprland"
arch=(x86_64)
license=(custom:MIT)
provides=("${pkgname%-git}" "xdg-desktop-portal-impl")
conflicts=("${pkgname%-git}")
-depends=(xdg-desktop-portal pipewire libinih qt6-base)
+depends=(xdg-desktop-portal pipewire libinih qt6-base qt6-wayland)
makedepends=(git meson wayland-protocols wayland scdoc cmake)
optdepends=(
"grim: required for the screenshot portal to function"
"slurp: support for interactive mode for the screenshot portal; one of the built-in chooser options for the screencast portal"
"bemenu: one of the built-in chooser options for the screencast portal"
"wofi: one of the built-in chooser options for the screencast portal"
- "obs-xdg-portal: support for the screencast portal in obs"
"hyprland: the Hyprland compositor"
)
source=("${_pkgname}::git+https://github.com/hyprwm/xdg-desktop-portal-hyprland.git")
@@ -36,14 +35,14 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
git submodule update --init
- meson build
+ meson build --prefix=/usr
ninja -C build
cd hyprland-share-picker && make all && cd ..
}
package() {
cd "${srcdir}/${_pkgname}"
- sudo ninja -C build install
+ DESTDIR="${pkgdir}" ninja -C build install
install -Dm755 hyprland-share-picker/build/hyprland-share-picker -t "${pkgdir}/usr/bin"
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${_pkgname}"
}