summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2021-10-24 14:32:40 +0800
committerChih-Hsuan Yen2021-10-24 14:32:40 +0800
commitf04a80d3232f568371c6333e46cc385fb33dccba (patch)
treeab0d9ae5ff2e18dbf1d8e4f563e3fb39d83c869b
downloadaur-f04a80d3232f568371c6333e46cc385fb33dccba.tar.gz
new package
See https://github.com/lxqt/lxqt/issues/2069
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..238676654ec5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = xdg-desktop-portal-lxqt-git
+ pkgdesc = A backend implementation for xdg-desktop-portal using Qt/KF5
+ pkgver = 0.0.0.r1.b3710c0
+ pkgrel = 1
+ url = https://github.com/lxqt/xdg-desktop-portal-lxqt
+ arch = x86_64
+ license = LGPL
+ makedepends = cmake
+ makedepends = git
+ depends = qt5-base
+ depends = kwindowsystem
+ provides = xdg-desktop-portal-impl
+ source = git+https://github.com/lxqt/xdg-desktop-portal-lxqt
+ sha256sums = SKIP
+
+pkgname = xdg-desktop-portal-lxqt-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01213c52738b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Chih-Hsuan Yen <yan12125@archlinux.org>
+# Modified from extra/xdg-desktop-portal-kde; original contributors:
+# Contributor: Antonio Rojas <arojas@archlinux.org>
+
+_pkgname=xdg-desktop-portal-lxqt
+pkgname=$_pkgname-git
+pkgver=0.0.0.r1.b3710c0
+pkgrel=1
+pkgdesc='A backend implementation for xdg-desktop-portal using Qt/KF5'
+arch=(x86_64)
+url='https://github.com/lxqt/xdg-desktop-portal-lxqt'
+license=(LGPL)
+depends=(qt5-base kwindowsystem)
+makedepends=(cmake git)
+provides=(xdg-desktop-portal-impl)
+source=(git+$url)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "0.0.0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cmake -B build -S $_pkgname \
+ -DCMAKE_INSTALL_LIBEXECDIR=lib \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}