summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Libert2024-06-19 15:59:28 +0200
committerBart Libert2024-06-19 15:59:28 +0200
commit1be18f46b27d12402c0841b68c276e4fcdf428a5 (patch)
treee1384c9aa1dd7404590e7c07a23606882bdecb08
downloadaur-1be18f46b27d12402c0841b68c276e4fcdf428a5.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore5
-rw-r--r--.pre-commit-config.yaml19
-rw-r--r--PKGBUILD41
4 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2c29d333a8ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = xdg-desktop-portal-termfilechooser-fix-for-lf-git
+ pkgdesc = xdg-desktop-portal backend for your favorite terminal file chooser with fix for lf
+ pkgver = r11.6acc64b
+ pkgrel = 1
+ url = https://github.com/boydaihungst/xdg-desktop-portal-termfilechooser
+ arch = x86_64
+ license = MIT
+ makedepends = meson
+ makedepends = scdoc
+ makedepends = git
+ depends = xdg-desktop-portal
+ depends = libinih
+ optdepends = lf: for choosing files
+ optdepends = kitty: default terminal for launching ranger
+ provides = xdg-desktop-portal-impl
+ conflicts = xdg-desktop-portal-termfilechooser-git
+ source = xdg-desktop-portal-termfilechooser-fix-for-lf-git::git+https://github.com/boydaihungst/xdg-desktop-portal-termfilechooser.git#branch=fix-for-lf
+ sha512sums = SKIP
+
+pkgname = xdg-desktop-portal-termfilechooser-fix-for-lf-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e69d7a6de40f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
+!.pre-commit-config.yaml
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
new file mode 100644
index 000000000000..07fd3db75be9
--- /dev/null
+++ b/.pre-commit-config.yaml
@@ -0,0 +1,19 @@
+---
+repos:
+ - repo: https://github.com/pre-commit/pre-commit-hooks
+ rev: v4.5.0
+ hooks:
+ - id: check-added-large-files
+ - id: check-case-conflict
+ - id: check-vcs-permalinks
+ - id: destroyed-symlinks
+ - id: detect-private-key
+ - id: end-of-file-fixer
+ - id: mixed-line-ending
+ - id: trailing-whitespace
+ - repo: https://github.com/edlanglois/pkgbuild-hooks
+ rev: v0.2.0
+ hooks:
+ - id: srcinfo-fixer
+ - id: verify-srcinfo-checksums
+default_install_hook_types: [pre-commit, commit-msg]
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..151bc6a25bc9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Bart Libert <bart plus aur at libert dot email>
+pkgname=xdg-desktop-portal-termfilechooser-fix-for-lf-git
+pkgver=r11.6acc64b
+pkgrel=1
+pkgdesc='xdg-desktop-portal backend for your favorite terminal file chooser with fix for lf'
+url="https://github.com/boydaihungst/xdg-desktop-portal-termfilechooser"
+arch=('x86_64')
+license=('MIT')
+provides=('xdg-desktop-portal-impl')
+depends=('xdg-desktop-portal' 'libinih')
+makedepends=('meson' 'scdoc' 'git')
+optdepends=(
+ 'lf: for choosing files'
+ 'kitty: default terminal for launching ranger'
+)
+source=(
+ "${pkgname}::git+$url.git#branch=fix-for-lf"
+)
+sha512sums=('SKIP')
+conflicts=(xdg-desktop-portal-termfilechooser-git)
+
+pkgver () {
+ cd "${pkgname}"
+ (
+ set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "${pkgname}"
+ arch-meson -Dsd-bus-provider=libsystemd build
+ ninja -C build
+}
+
+package() {
+ cd "${pkgname}"
+ DESTDIR="${pkgdir}" ninja -C build install
+ install -Dm644 -t "$pkgdir/usr/share/licenses/${pkgname}" LICENSE
+}