summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Tatschner2020-05-05 18:29:57 +0200
committerStefan Tatschner2020-05-05 18:29:57 +0200
commiteb5709255504b8a4a07990e16ae964d6f2fa853b (patch)
tree2bac2e7ff67fa02fa5e82536c2267663cfba40f4
downloadaur-eb5709255504b8a4a07990e16ae964d6f2fa853b.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1cdda19fd682
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = xdg-desktop-portal-wlr
+ pkgdesc = xdg-desktop-portal backend for wlroots
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/emersion/xdg-desktop-portal-wlr
+ arch = x86_64
+ license = MIT
+ makedepends = meson
+ makedepends = wayland-protocols
+ makedepends = wayland
+ depends = wlroots
+ depends = xdg-desktop-portal
+ depends = pipewire
+ source = xdg-desktop-portal-wlr-0.1.0::https://github.com/emersion/xdg-desktop-portal-wlr/archive/v0.1.0.tar.gz
+ sha256sums = 69d67c236f4bd498323af509d44ec4a1b826da337f7ee64bbfbdb98bfda8e541
+
+pkgname = xdg-desktop-portal-wlr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35e450963fde
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Stefan Tatschner <stefan@rumpelsepp.org>
+
+pkgname=xdg-desktop-portal-wlr
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='xdg-desktop-portal backend for wlroots'
+url=https://github.com/emersion/xdg-desktop-portal-wlr
+arch=(x86_64)
+license=(MIT)
+depends=(wlroots xdg-desktop-portal pipewire)
+makedepends=(meson wayland-protocols wayland)
+source=(
+ "${pkgname}-${pkgver}::https://github.com/emersion/xdg-desktop-portal-wlr/archive/v${pkgver}.tar.gz"
+)
+sha256sums=('69d67c236f4bd498323af509d44ec4a1b826da337f7ee64bbfbdb98bfda8e541')
+
+build () {
+ cd "${pkgname}-${pkgver}"
+ arch-meson build
+ ninja -C build
+}
+
+package () {
+ cd "${pkgname}-${pkgver}"
+ DESTDIR="${pkgdir}" ninja -C build install
+}
+