summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoremma2022-09-02 01:19:14 -0400
committeremma2022-09-02 01:19:14 -0400
commit8687d02b881b647dc724635333b8cadae2cedeb5 (patch)
treedf6e33497b83d735ec964308d67dabf182fdc75f
parentc78129169e4ccf1f051ee50c5b4ac15d1d91cc86 (diff)
downloadaur-8687d02b881b647dc724635333b8cadae2cedeb5.tar.gz
fixed desktop file and program command
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a121a40c1669..0570ee8c8bd3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xdg-sanity
pkgdesc = A tool to sanely open http/s links.
pkgver = 0.1
- pkgrel = 2
+ pkgrel = 3
url = https://git.tebibyte.media/emma/xdg-sanity
arch = any
license = AGPL3
diff --git a/PKGBUILD b/PKGBUILD
index d37a7a2c1fb0..f9120285725e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname="xdg-sanity"
pkgver=0.1
-pkgrel=2
+pkgrel=3
pkgdesc="A tool to sanely open http/s links."
arch=("any")
url="https://git.tebibyte.media/emma/xdg-sanity"
@@ -15,11 +15,16 @@ provides=("xdg-sanity")
sha256sums=("SKIP")
+prepare() {
+ cd ..
+ gendesk -n PKGBUILD
+ mv "xdg-sanity.desktop" "${srcdir}"
+}
+
package() {
cd $srcdir/
mkdir -p "${pkgdir}/usr/local/bin"
mkdir -p "${pkgdir}/usr/share/applications"
- mv "${srcdir}/${pkgname}/xdg-sanity.sh" "${pkgdir}/usr/local/bin"
- gendesk -n --exec xdg-desktop.sh PKGBUILD
- mv xdg-sanity.desktop "${pkgdir}/usr/share/applications"
+ mv "${srcdir}/${pkgname}/xdg-sanity.sh" "${pkgdir}/usr/local/bin/xdg-sanity"
+ mv "xdg-sanity.desktop" "${pkgdir}/usr/share/applications"
} \ No newline at end of file