summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralexandruianu2015-07-13 21:54:05 +0300
committeralexandruianu2015-07-13 21:54:05 +0300
commitbda280defb15e2484a8fe7b6eee39c63e1871cf2 (patch)
treeddbeef740885fe04ae834946495a8e21a0b0c4d9
downloadaur-bda280defb15e2484a8fe7b6eee39c63e1871cf2.tar.gz
moved and taken
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b760e7012a9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = xdg-su
+ pkgdesc = Run a program as root with the most environment appropriate available graphical authentication agent
+ pkgver = 1.2.3
+ pkgrel = 1
+ url = https://github.com/tarakbumba/xdg-su
+ arch = any
+ license = MIT
+ makedepends = links
+ makedepends = xmlto
+ makedepends = docbook-xsl
+ depends = sh
+ source = https://github.com/tarakbumba/xdg-su/archive/xdg-su-1.2.3.tar.gz
+ sha1sums = e92fd399b39f7b38d7bbfc7b834c78e551b2eee5
+
+pkgname = xdg-su
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c27f85e7d6b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer : Rob McCathie aka korrode <archaur at rmcc dot com dot au>
+# Contributor: Atilla ÖNTAŞ <tarakbumba@gmail.com>
+# Contributor: Mitchell Nemitz <mitchell.nemitz@gmail.com>
+# Contributor: sebcactus <sebcactus@gmail.com>
+
+pkgname=xdg-su
+pkgver=1.2.3
+pkgrel=1
+pkgdesc="Run a program as root with the most environment appropriate available graphical authentication agent"
+arch=('any')
+url="https://github.com/tarakbumba/xdg-su"
+license=('MIT')
+depends=('sh')
+makedepends=('links' 'xmlto' 'docbook-xsl')
+source=("https://github.com/tarakbumba/${pkgname}/archive/${pkgname}-${pkgver}.tar.gz")
+sha1sums=('e92fd399b39f7b38d7bbfc7b834c78e551b2eee5')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}