summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2022-09-28 06:13:12 +0200
committerCarl Smedstad2022-09-28 06:13:12 +0200
commit3cc20876a6b330aa697e4a7407396eac211d9a42 (patch)
tree6af6f0dcc86a06f2bd608aca4b04cd75a10799d8
parentabadf46c8e92121dff968e2c50c5adbfa9bdb414 (diff)
downloadaur-3cc20876a6b330aa697e4a7407396eac211d9a42.tar.gz
Publish version 0.6.4
I assumed the intenion was to track the version of handlr, so I've bumped the version to that. Other changes: * Added checksum * Added .gitignore * Added dependency to handlr-bin * Quoted variables in package()
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD18
3 files changed, 18 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6bc9ddfb1863..12a378c235ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = xdg-utils-handlr
pkgdesc = A shim for xdg-utils to use handlr under the hood
- pkgver = 0.3.1
- pkgrel = 2
+ pkgver = 0.6.4
+ pkgrel = 1
url = https://github.com/chmln/handlr
arch = x86_64
license = MIT
+ depends = handlr-bin
provides = xdg-utils
conflicts = xdg-utils
conflicts = xdg-utils-mimeo
source = xdg-open
- sha256sums = SKIP
+ sha256sums = 21fae4188078463026d6d30bda53483c3e27a1915b1f4a8cb1ae0437d4aca87e
pkgname = xdg-utils-handlr
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index f9ff0a93b30d..299ef8d1bc89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,20 @@
+# Maintainer: Carl Smedstad <carl.smedstad at protonmail dot com>
# Maintainer: Gregory <gregory.mkv@gmail.com
+
pkgname=xdg-utils-handlr
-pkgver=0.3.1
-pkgrel=2
+pkgver=0.6.4
+pkgrel=1
pkgdesc="A shim for xdg-utils to use handlr under the hood"
arch=('x86_64')
-url="https://github.com/chmln/handlr"
+url='https://github.com/chmln/handlr'
license=('MIT')
-groups=()
-depends=()
+depends=('handlr-bin')
provides=('xdg-utils')
conflicts=('xdg-utils' 'xdg-utils-mimeo')
-source=("xdg-open")
-sha256sums=('SKIP')
+
+source=('xdg-open')
+sha256sums=('21fae4188078463026d6d30bda53483c3e27a1915b1f4a8cb1ae0437d4aca87e')
package() {
- install -Dm755 $srcdir/xdg-open $pkgdir/usr/bin/xdg-open
+ install -Dm755 "$srcdir/xdg-open" "$pkgdir/usr/bin/xdg-open"
}