summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2019-09-26 21:05:10 +0200
committerNarrat2019-09-26 21:05:10 +0200
commit059b0ac0fcd9bad546c61fcd5d5b2a55378e8f87 (patch)
tree9431d4c7b1e1a7a0b9738f64182d6d120fcee1b1
parente72622a452018c4dfb9ade8e6cfccd272d612b77 (diff)
downloadaur-059b0ac0fcd9bad546c61fcd5d5b2a55378e8f87.tar.gz
xdg-utils-mimeo: Fix for xdg-mime
What xdg-mime reports back is kinda fixed and caused problems with programs relying on this script, as the unfiltered mimeo output was printed.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--mimeo-detection.patch8
3 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb361fc2db38..935122659c7e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xdg-utils-mimeo
pkgdesc = Command line tools that assist applications with a variety of desktop integration tasks; patched to use mimeo
pkgver = 1.1.3+18+g0547886
- pkgrel = 1
+ pkgrel = 2
url = https://www.freedesktop.org/wiki/Software/xdg-utils/
arch = any
license = MIT
@@ -23,7 +23,7 @@ pkgbase = xdg-utils-mimeo
conflicts = xdg-utils
source = mimeo-detection.patch
source = git+https://gitlab.freedesktop.org/xdg/xdg-utils.git#commit=0547886c0a7ae79145998495a6e3af6a1450d0c7
- sha1sums = ef21b3afb270e38a56bdc4f3188509d7f192eede
+ sha1sums = 28204f4da29c1afb9b67ba073441a2784301e586
sha1sums = SKIP
pkgname = xdg-utils-mimeo
diff --git a/PKGBUILD b/PKGBUILD
index a4ab870ae5b3..ef2e2583d6ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgname=$_pkgname-mimeo
# https://gitlab.freedesktop.org/xdg/xdg-utils/commits/master
_commit=0547886c0a7ae79145998495a6e3af6a1450d0c7 # master # 2019-04-19
pkgver=1.1.3+18+g0547886
-pkgrel=1
+pkgrel=2
pkgdesc="Command line tools that assist applications with a variety of desktop integration tasks; patched to use mimeo"
arch=('any')
url="https://www.freedesktop.org/wiki/Software/xdg-utils/"
@@ -29,7 +29,7 @@ conflicts=($_pkgname)
source=(#https://portland.freedesktop.org/download/$_pkgname-$pkgver.tar.gz #{,.asc}
mimeo-detection.patch
"git+https://gitlab.freedesktop.org/xdg/xdg-utils.git#commit=$_commit")
-sha1sums=('ef21b3afb270e38a56bdc4f3188509d7f192eede'
+sha1sums=('28204f4da29c1afb9b67ba073441a2784301e586'
'SKIP')
#validpgpkeys=('8B75CA7811367175D05F3B03C43570F80CC295E6') # "Per Olofsson <pelle@pqz.se>"
diff --git a/mimeo-detection.patch b/mimeo-detection.patch
index bab155feba6f..d7911fa7a715 100644
--- a/mimeo-detection.patch
+++ b/mimeo-detection.patch
@@ -1,6 +1,6 @@
-commit 35cb4e638d6b3f807c2cf3806faedf5e59f2821b
+commit d39d0ebd0c93dc5a589b81dc8909db8fc64baafd
Author: Narrat <autumn-wind@web.de>
-Date: Mon May 8 21:12:37 2017 +0200
+Date: Thu Sep 26 21:01:53 2019 +0200
Add support for mimeo
@@ -39,7 +39,7 @@ index 6db58ad..70b539a 100644
open_generic "${mailto}"
;;
diff --git a/scripts/xdg-mime.in b/scripts/xdg-mime.in
-index 034d0ef..7352799 100644
+index 034d0ef..88c0ae3 100644
--- a/scripts/xdg-mime.in
+++ b/scripts/xdg-mime.in
@@ -95,6 +95,16 @@ info_gnome()
@@ -48,7 +48,7 @@ index 034d0ef..7352799 100644
+info_mimeo()
+{
-+ mimeo -m "$1"
++ mimeo -m "$1" | awk 'FNR == 2 {print}' | cut -d' ' -f3
+ if [ $? -eq 0 ]; then
+ exit_success
+ else