summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2020-04-13 16:02:38 +0200
committerNarrat2020-04-13 16:02:38 +0200
commit1c188396ae2282de062dc05b85cbe51cecc01d42 (patch)
tree7419a6514e50d94ce86d1da51ed3f9a45ccaa42a
parentf2261c36690d44d3ccb956872469749fa79aa5dd (diff)
downloadaur-1c188396ae2282de062dc05b85cbe51cecc01d42.tar.gz
xdg-utils-mimeo: Small adjustment
While taking a first look at the reported issue with the flatpack firefox, I noticed something in regards setting the protocols. It was just setting for http, whereas every other set http, https and some more.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--mimeo-detection.patch16
3 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 87898e1b662d..6d0197707247 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xdg-utils-mimeo
pkgdesc = Command line tools that assist applications with a variety of desktop integration tasks; patched to use mimeo
pkgver = 1.1.3+19+g9816ebb
- pkgrel = 1
+ pkgrel = 2
url = https://www.freedesktop.org/wiki/Software/xdg-utils/
arch = any
license = MIT
@@ -25,7 +25,7 @@ pkgbase = xdg-utils-mimeo
conflicts = xdg-utils
source = mimeo-detection.patch
source = git+https://gitlab.freedesktop.org/xdg/xdg-utils.git#commit=9816ebb3e6fd9f23e993b8b7fcbd56f92d9c9197
- sha1sums = 28204f4da29c1afb9b67ba073441a2784301e586
+ sha1sums = 698507491a9d6221c141e69595ff4b53fa67cfe5
sha1sums = SKIP
pkgname = xdg-utils-mimeo
diff --git a/PKGBUILD b/PKGBUILD
index 08235e64eb4d..c8f317c0dfb4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgname=$_pkgname-mimeo
# https://gitlab.freedesktop.org/xdg/xdg-utils/commits/master
_commit=9816ebb3e6fd9f23e993b8b7fcbd56f92d9c9197 # master # 2020-02-20
pkgver=1.1.3+19+g9816ebb
-pkgrel=1
+pkgrel=2
pkgdesc="Command line tools that assist applications with a variety of desktop integration tasks; patched to use mimeo"
arch=('any')
url="https://www.freedesktop.org/wiki/Software/xdg-utils/"
@@ -28,7 +28,7 @@ conflicts=($_pkgname)
source=(#https://portland.freedesktop.org/download/$_pkgname-$pkgver.tar.gz #{,.asc}
mimeo-detection.patch
"git+https://gitlab.freedesktop.org/xdg/xdg-utils.git#commit=$_commit")
-sha1sums=('28204f4da29c1afb9b67ba073441a2784301e586'
+sha1sums=('698507491a9d6221c141e69595ff4b53fa67cfe5'
'SKIP')
#validpgpkeys=('8B75CA7811367175D05F3B03C43570F80CC295E6') # "Per Olofsson <pelle@pqz.se>"
diff --git a/mimeo-detection.patch b/mimeo-detection.patch
index d7911fa7a715..a55bbadffae8 100644
--- a/mimeo-detection.patch
+++ b/mimeo-detection.patch
@@ -1,6 +1,6 @@
-commit d39d0ebd0c93dc5a589b81dc8909db8fc64baafd
+commit bd3e1905f54b06ff5ca541272253fcee7aba4819
Author: Narrat <autumn-wind@web.de>
-Date: Thu Sep 26 21:01:53 2019 +0200
+Date: Mon Apr 13 15:59:44 2020 +0200
Add support for mimeo
@@ -117,10 +117,10 @@ index 95f707e..9c2f511 100644
;;
esac
diff --git a/scripts/xdg-settings.in b/scripts/xdg-settings.in
-index 3781de8..6ec7c70 100644
+index 3781de8..e6ea67b 100644
--- a/scripts/xdg-settings.in
+++ b/scripts/xdg-settings.in
-@@ -471,6 +471,42 @@ set_browser_xfce()
+@@ -471,6 +471,44 @@ set_browser_xfce()
}
# }}} xfce
@@ -151,7 +151,9 @@ index 3781de8..6ec7c70 100644
+set_browser_mimeo()
+{
+ DEBUG 1 "Running mimeo --prefer x-scheme-handler/http \"$1\""
-+ mimeo --prefer x-scheme-handler/http \"$1\"
++ for protocol in http https about unknown; do
++ mimeo --prefer x-scheme-handler/$protocol \"$1\" || return
++ done
+ if [ $? -eq 0 ]; then
+ exit_success
+ else
@@ -163,7 +165,7 @@ index 3781de8..6ec7c70 100644
# {{{ generic
get_browser_generic()
-@@ -713,6 +749,24 @@ set_url_scheme_handler_xfce()
+@@ -713,6 +751,24 @@ set_url_scheme_handler_xfce()
}
# }}} xfce
@@ -188,7 +190,7 @@ index 3781de8..6ec7c70 100644
# {{{ generic
get_url_scheme_handler_generic()
-@@ -867,6 +921,10 @@ case "$DE" in
+@@ -867,6 +923,10 @@ case "$DE" in
dispatch_specific xfce "$@"
;;