summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2020-04-19 20:19:27 +0200
committerNarrat2020-04-19 20:19:27 +0200
commit4c069c909e6030f0db04990cca95088067473f0d (patch)
tree469a3e3e48457e8a8d580281c344fb93ee063346
parent1c188396ae2282de062dc05b85cbe51cecc01d42 (diff)
downloadaur-4c069c909e6030f0db04990cca95088067473f0d.tar.gz
xdg-utils-mimeo: Fix bug with setting default apps
Thanks to cosmic for this detail, as it indeed caused the setting of default apps to fail.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--mimeo-detection.patch22
3 files changed, 20 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d0197707247..01fefaa77d67 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xdg-utils-mimeo
pkgdesc = Command line tools that assist applications with a variety of desktop integration tasks; patched to use mimeo
pkgver = 1.1.3+19+g9816ebb
- pkgrel = 2
+ pkgrel = 3
url = https://www.freedesktop.org/wiki/Software/xdg-utils/
arch = any
license = MIT
@@ -25,7 +25,7 @@ pkgbase = xdg-utils-mimeo
conflicts = xdg-utils
source = mimeo-detection.patch
source = git+https://gitlab.freedesktop.org/xdg/xdg-utils.git#commit=9816ebb3e6fd9f23e993b8b7fcbd56f92d9c9197
- sha1sums = 698507491a9d6221c141e69595ff4b53fa67cfe5
+ sha1sums = 6fca8e78a7281c7760076e2947e5b7d71503fe09
sha1sums = SKIP
pkgname = xdg-utils-mimeo
diff --git a/PKGBUILD b/PKGBUILD
index c8f317c0dfb4..25381fb06275 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgname=$_pkgname-mimeo
# https://gitlab.freedesktop.org/xdg/xdg-utils/commits/master
_commit=9816ebb3e6fd9f23e993b8b7fcbd56f92d9c9197 # master # 2020-02-20
pkgver=1.1.3+19+g9816ebb
-pkgrel=2
+pkgrel=3
pkgdesc="Command line tools that assist applications with a variety of desktop integration tasks; patched to use mimeo"
arch=('any')
url="https://www.freedesktop.org/wiki/Software/xdg-utils/"
@@ -28,7 +28,7 @@ conflicts=($_pkgname)
source=(#https://portland.freedesktop.org/download/$_pkgname-$pkgver.tar.gz #{,.asc}
mimeo-detection.patch
"git+https://gitlab.freedesktop.org/xdg/xdg-utils.git#commit=$_commit")
-sha1sums=('698507491a9d6221c141e69595ff4b53fa67cfe5'
+sha1sums=('6fca8e78a7281c7760076e2947e5b7d71503fe09'
'SKIP')
#validpgpkeys=('8B75CA7811367175D05F3B03C43570F80CC295E6') # "Per Olofsson <pelle@pqz.se>"
diff --git a/mimeo-detection.patch b/mimeo-detection.patch
index a55bbadffae8..960d248dab83 100644
--- a/mimeo-detection.patch
+++ b/mimeo-detection.patch
@@ -1,6 +1,6 @@
-commit bd3e1905f54b06ff5ca541272253fcee7aba4819
+commit 26aeded432434afe7152e30e34b0c820a5567b93
Author: Narrat <autumn-wind@web.de>
-Date: Mon Apr 13 15:59:44 2020 +0200
+Date: Sun Apr 19 20:06:49 2020 +0200
Add support for mimeo
@@ -117,7 +117,7 @@ index 95f707e..9c2f511 100644
;;
esac
diff --git a/scripts/xdg-settings.in b/scripts/xdg-settings.in
-index 3781de8..e6ea67b 100644
+index 3781de8..e60fe95 100644
--- a/scripts/xdg-settings.in
+++ b/scripts/xdg-settings.in
@@ -471,6 +471,44 @@ set_browser_xfce()
@@ -152,7 +152,7 @@ index 3781de8..e6ea67b 100644
+{
+ DEBUG 1 "Running mimeo --prefer x-scheme-handler/http \"$1\""
+ for protocol in http https about unknown; do
-+ mimeo --prefer x-scheme-handler/$protocol \"$1\" || return
++ mimeo --prefer x-scheme-handler/$protocol "$1" || return
+ done
+ if [ $? -eq 0 ]; then
+ exit_success
@@ -202,10 +202,20 @@ index 3781de8..e6ea67b 100644
dispatch_specific generic "$@"
;;
diff --git a/scripts/xdg-utils-common.in b/scripts/xdg-utils-common.in
-index b4333e2..983d261 100644
+index b4333e2..10b3ebf 100644
--- a/scripts/xdg-utils-common.in
+++ b/scripts/xdg-utils-common.in
-@@ -319,6 +319,7 @@ detectDE()
+@@ -303,6 +303,9 @@ detectDE()
+ XFCE)
+ DE=xfce
+ ;;
++ MIMEO|mimeo)
++ DE=xfce
++ ;;
+ X-Generic)
+ DE=generic
+ ;;
+@@ -319,6 +322,7 @@ detectDE()
elif xprop -root 2> /dev/null | grep -i '^xfce_desktop_window' >/dev/null 2>&1; then DE=xfce
elif echo $DESKTOP | grep -q '^Enlightenment'; then DE=enlightenment;
elif [ x"$LXQT_SESSION_CONFIG" != x"" ]; then DE=lxqt;