summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2022-09-14 19:33:00 +0200
committerNarrat2022-09-14 19:33:00 +0200
commit6ca6eb62c0e782b1ad54e2f9eb931c43c678b349 (patch)
tree9fade69c739bcd5b01dfe0ece8bc0821f83dd1b8
parentc33f8d977efc64c10df4755dd0f01803f31cf523 (diff)
downloadaur-6ca6eb62c0e782b1ad54e2f9eb931c43c678b349.tar.gz
xdg-utils-mimeo: follow Arch
In this case add the patch regarding the egrep deprecation.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9be2dddf8e33..6672caea87cf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xdg-utils-mimeo
pkgdesc = Command line tools that assist applications with a variety of desktop integration tasks; patched to use mimeo
pkgver = 1.1.3+21+g1a58bc2
- pkgrel = 1
+ pkgrel = 2
url = https://www.freedesktop.org/wiki/Software/xdg-utils/
arch = any
license = MIT
@@ -25,7 +25,9 @@ pkgbase = xdg-utils-mimeo
conflicts = xdg-utils
source = mimeo-detection.patch
source = git+https://gitlab.freedesktop.org/xdg/xdg-utils.git#commit=1a58bc28f6844898532daf9ee1bf6da7764955a9
+ source = egrep_is_obsolete.patch::https://gitlab.freedesktop.org/xdg/xdg-utils/-/merge_requests/21.patch
sha256sums = e5a69feba0e2ded0071118034d19309adc99321ab880a4ac5be64a1e9a506aa0
sha256sums = SKIP
+ sha256sums = 550a8db792bb810168583be02e0c9e665a7a6ce245b48424188be235e35d4799
pkgname = xdg-utils-mimeo
diff --git a/PKGBUILD b/PKGBUILD
index 2429f8368318..28c9da2180ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgname=$_pkgname-mimeo
# https://gitlab.freedesktop.org/xdg/xdg-utils/commits/master
_commit=1a58bc28f6844898532daf9ee1bf6da7764955a9 # master # 2021-08-05
pkgver=1.1.3+21+g1a58bc2
-pkgrel=1
+pkgrel=2
pkgdesc="Command line tools that assist applications with a variety of desktop integration tasks; patched to use mimeo"
arch=('any')
url="https://www.freedesktop.org/wiki/Software/xdg-utils/"
@@ -27,9 +27,11 @@ provides=($_pkgname)
conflicts=($_pkgname)
source=(#https://portland.freedesktop.org/download/$_pkgname-$pkgver.tar.gz #{,.asc}
mimeo-detection.patch
- "git+https://gitlab.freedesktop.org/xdg/xdg-utils.git#commit=$_commit")
+ "git+https://gitlab.freedesktop.org/xdg/xdg-utils.git#commit=$_commit"
+ egrep_is_obsolete.patch::https://gitlab.freedesktop.org/xdg/xdg-utils/-/merge_requests/21.patch)
sha256sums=('e5a69feba0e2ded0071118034d19309adc99321ab880a4ac5be64a1e9a506aa0'
- 'SKIP')
+ 'SKIP'
+ '550a8db792bb810168583be02e0c9e665a7a6ce245b48424188be235e35d4799')
#validpgpkeys=('8B75CA7811367175D05F3B03C43570F80CC295E6') # "Per Olofsson <pelle@pqz.se>"
pkgver() {
@@ -39,6 +41,10 @@ pkgver() {
prepare() {
cd $_pkgname #-$pkgver
+
+ # switch from non-standard "egrep" to POSIX "grep -E"
+ patch -Np1 -i ../egrep_is_obsolete.patch
+
patch -p1 -i "${srcdir}"/mimeo-detection.patch
}